aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mysql323-server
diff options
context:
space:
mode:
authormbr <mbr@FreeBSD.org>2003-03-27 07:27:15 +0800
committermbr <mbr@FreeBSD.org>2003-03-27 07:27:15 +0800
commit90ea019e0c9512d2974509e169cacdedca20fd0b (patch)
tree98506ee09b277bd8241bf5d86ab8063a61e7d231 /databases/mysql323-server
parent4fc8e56042eec3f5768f955791ec9af5ad001fa1 (diff)
downloadfreebsd-ports-gnome-90ea019e0c9512d2974509e169cacdedca20fd0b.tar.gz
freebsd-ports-gnome-90ea019e0c9512d2974509e169cacdedca20fd0b.tar.zst
freebsd-ports-gnome-90ea019e0c9512d2974509e169cacdedca20fd0b.zip
Under FreeBSD 5.X, libstdc++ and libsupc++ in /usr/lib use FreeBSD
native (libc_r style) mutexes, thus some of the linked application might indirectly try to pass native style mutexes to linuxthreads pthread functions, either hanging at program startup or overwriting data following the native style mutex. <tegge> Reviewed by: tegge
Diffstat (limited to 'databases/mysql323-server')
-rw-r--r--databases/mysql323-server/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/databases/mysql323-server/Makefile b/databases/mysql323-server/Makefile
index 2baf43e55f70..eead9343d6ad 100644
--- a/databases/mysql323-server/Makefile
+++ b/databases/mysql323-server/Makefile
@@ -57,11 +57,14 @@ CONFIGURE_ARGS+=--with-mysqld-ldflags=--static
CFLAGS+= -mcpu=pentiumpro -O3
.endif
.if defined(WITH_LINUXTHREADS)
-CONFIGURE_ARGS+=--with-named-thread-libs='-DHAVE_GLIBC2_STYLE_GETHOSTBYNAME_R -D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads -L${LOCALBASE}/lib -llthread -llgcc_r'
+CONFIGURE_ARGS+=--with-named-thread-libs='-DHAVE_GLIBC2_STYLE_GETHOSTBYNAME_R
+CONFIGURE_ARGS+=-D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
CFLAGS+= -D__USE_UNIX98 -D_REENTRANT -D_THREAD_SAFE -I${LOCALBASE}/include/pthread/linuxthreads
.if ${OSVERSION} > 500000
+CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r -llstdc++ -llsupc++'
LIB_DEPENDS+= lthread.3:${PORTSDIR}/devel/linuxthreads
.else
+CONFIGURE_ARGS+=-L${LOCALBASE}/lib -llthread -llgcc_r'
LIB_DEPENDS+= lthread.2:${PORTSDIR}/devel/linuxthreads
.endif
.endif