aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mysql51-server
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-04-04 13:21:36 +0800
committernork <nork@FreeBSD.org>2003-04-04 13:21:36 +0800
commitc5524f28dda3bb870ac090988881908d743bb201 (patch)
treee6dedfea4a27bc32a70825315877d27ff6d6604d /databases/mysql51-server
parent74e9f49df325f63cb9ecacb48c18a0c6685f6ecb (diff)
downloadfreebsd-ports-gnome-c5524f28dda3bb870ac090988881908d743bb201.tar.gz
freebsd-ports-gnome-c5524f28dda3bb870ac090988881908d743bb201.tar.zst
freebsd-ports-gnome-c5524f28dda3bb870ac090988881908d743bb201.zip
o Move USE_PERL5_RUN into server part.
o Switch from p5-Mysql to p5-DBD-mysql. o Add MySQL 4 support (and set it as default) to p5-DBD-mysql. o Bump PORTREVISION accordingly. PR: ports/50315 Submitted by: Alex Dupre <sysadmin@alexdupre.com> (mysql40 maintainer) Approved by: skv (p5-DBD-myql maintainer)
Diffstat (limited to 'databases/mysql51-server')
-rw-r--r--databases/mysql51-server/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/databases/mysql51-server/Makefile b/databases/mysql51-server/Makefile
index 7f4a067cff34..2c9dcc3717e3 100644
--- a/databases/mysql51-server/Makefile
+++ b/databases/mysql51-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mysql
PORTVERSION= 4.0.12
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= databases
MASTER_SITES= ftp://mysql.secsup.org/pub/software/mysql/Downloads/MySQL-4.0/ \
http://mysql.tzone.it/Downloads/MySQL-4.0/ \
@@ -29,7 +29,6 @@ COMMENT?= Multithreaded SQL database (server)
SLAVEDIRS= databases/mysql40-client
DB_DIR?= /var/db/mysql
-USE_PERL5_RUN= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
@@ -94,8 +93,10 @@ CXX= ${CC}
# MySQL-Server part
.if !defined(CLIENT_ONLY)
+USE_PERL5_RUN= yes
+
RUN_DEPENDS= mysql:${PORTSDIR}/databases/mysql40-client \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-Mysql
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
PLIST_SUB= MYSQL_VERSION=${PORTVERSION}