aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mysql51-server
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2001-01-07 22:51:48 +0800
committerdirk <dirk@FreeBSD.org>2001-01-07 22:51:48 +0800
commitbd4c25410158cc3d723d1146727acefa85838341 (patch)
tree925bb9541d3f3ba4d9027f160e0f63d168cca594 /databases/mysql51-server
parentcde62bf8127bc5dc6768d9639625bea1b9a08829 (diff)
downloadfreebsd-ports-gnome-bd4c25410158cc3d723d1146727acefa85838341.tar.gz
freebsd-ports-gnome-bd4c25410158cc3d723d1146727acefa85838341.tar.zst
freebsd-ports-gnome-bd4c25410158cc3d723d1146727acefa85838341.zip
Add "-felide-constructors -fno-exceptions -fno-rtti" to CXXFLAGS
to work around a problem causing mysqld to crash under heavy load and multiple connections at the same time. PORTREVISION bumped.
Diffstat (limited to 'databases/mysql51-server')
-rw-r--r--databases/mysql51-server/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/databases/mysql51-server/Makefile b/databases/mysql51-server/Makefile
index b952e987c71c..3eacfb2ad9e6 100644
--- a/databases/mysql51-server/Makefile
+++ b/databases/mysql51-server/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= ${MASTERPORTNAME}
PORTVERSION= 3.23.30
+PORTREVISION?= 1
CATEGORIES= databases
MASTER_SITES= http://www.wipol.uni-bonn.de/MySQL/Downloads/MySQL-3.23/ \
http://www.mysql.net/Downloads/MySQL-3.23/ \
@@ -37,6 +38,9 @@ CONFIGURE_ENV+= PERL=${PERL} \
PERL5=${PERL} \
INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
CONFIGURE_ARGS="${CONFIGURE_ARGS}"
+# without including these flags mysqld may crash under heavy load
+# and multiple connections at the same time
+CXXFLAGS= ${CFLAGS} -felide-constructors -fno-exceptions -fno-rtti
# MySQL-Server part
.if !defined(CLIENT_ONLY)