aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mysql54-server/Makefile
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2002-11-13 18:38:20 +0800
committerdirk <dirk@FreeBSD.org>2002-11-13 18:38:20 +0800
commit10c836257ca59a8f77a9f635cad6c9e68c2161df (patch)
tree5600bd36e8d762fa953d2394b71fc897044c6541 /databases/mysql54-server/Makefile
parenta203068bfd4076371b8075eb863d360d993131ef (diff)
downloadfreebsd-ports-gnome-10c836257ca59a8f77a9f635cad6c9e68c2161df.tar.gz
freebsd-ports-gnome-10c836257ca59a8f77a9f635cad6c9e68c2161df.tar.zst
freebsd-ports-gnome-10c836257ca59a8f77a9f635cad6c9e68c2161df.zip
-STABLE exits with signal 11 while connecting via TCP/IP if empty
prototypes are used. -CURRENT needs empty prototypes to build. Use __FreeBSD_version to differentiate. Set CXX to $CC on -STABLE again to get around stability problems under heavy load.
Diffstat (limited to 'databases/mysql54-server/Makefile')
-rw-r--r--databases/mysql54-server/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/databases/mysql54-server/Makefile b/databases/mysql54-server/Makefile
index 3f507e4537b2..dab4c5e45cbc 100644
--- a/databases/mysql54-server/Makefile
+++ b/databases/mysql54-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= ${MASTERPORTNAME}
PORTVERSION= 3.23.53
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.kernelnotes.de/MySQL/Downloads/MySQL-3.23/ \
@@ -72,6 +72,9 @@ CXXFLAGS= ${CFLAGS} -felide-constructors -fno-rtti
.if ${OSVERSION} >= 400002
CXXFLAGS+= -fno-exceptions
.endif
+.if ${OSVERSION} < 500000
+CONFIGURE_ENV+= CXX="${CC}"
+.endif
# MySQL-Server part
.if !defined(CLIENT_ONLY)