aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mysql55-client/Makefile
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2010-12-27 23:02:38 +0800
committerale <ale@FreeBSD.org>2010-12-27 23:02:38 +0800
commit88e044153d15d7cac27ea4bc4b168f483de8875f (patch)
treebc47679b85e9f13fd1ac9f5134aa26bc332babfd /databases/mysql55-client/Makefile
parent388ba23e129a7d885a1058cb1ab91886418ad42c (diff)
downloadfreebsd-ports-gnome-88e044153d15d7cac27ea4bc4b168f483de8875f.tar.gz
freebsd-ports-gnome-88e044153d15d7cac27ea4bc4b168f483de8875f.tar.zst
freebsd-ports-gnome-88e044153d15d7cac27ea4bc4b168f483de8875f.zip
Update MySQL to 5.5.8 GA release. Read UPDATING.
Major changes: - new installation layout, resembling RPM packages: - client = Client Utilities + Development Libraries + Shared components - server = MySQL Server + Embedded - new build system: cmake instead of autotools - fewer port knobs Expect various breakages, but if we are lucky this could become the new default mysql port.
Diffstat (limited to 'databases/mysql55-client/Makefile')
-rw-r--r--databases/mysql55-client/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/databases/mysql55-client/Makefile b/databases/mysql55-client/Makefile
index 3eb647f81b9e..32f9ee0dfbeb 100644
--- a/databases/mysql55-client/Makefile
+++ b/databases/mysql55-client/Makefile
@@ -12,9 +12,21 @@ COMMENT= Multithreaded SQL database (client)
MASTERDIR= ${.CURDIR}/../mysql55-server
-PKGINSTALL= mustnotexist
PKGMESSAGE= mustnotexist
-PLIST= ${PKGDIR}/pkg-plist.client
+PATCHDIR= ${.CURDIR}/files
+PLIST= ${.CURDIR}/pkg-plist
+
+LATEST_LINK= mysql55-client
+
+CONFLICTS= mysql-client-[34].* mysql-client-5.[0-46-9].*
+
+CMAKE_ARGS= -DWITHOUT_SERVER="ON"
+
+USE_LDCONFIG= yes
+
+MAN1= comp_err.1 msql2mysql.1 mysql.1 mysql_config.1 mysql_find_rows.1 \
+ mysql_waitpid.1 mysqlaccess.1 mysqladmin.1 mysqlbinlog.1 \
+ mysqlcheck.1 mysqldump.1 mysqlimport.1 mysqlshow.1 mysqlslap.1
CLIENT_ONLY= yes