aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mysql55-server/Makefile
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-03-17 15:06:04 +0800
committerale <ale@FreeBSD.org>2006-03-17 15:06:04 +0800
commitc629ca332e82eda8b5a46cb004983621e8b5d8d8 (patch)
tree1a1b3219f201b4eb4d8b7337f04a509a05ab6c9b /databases/mysql55-server/Makefile
parentbf6ce9b408b535e52b7b7405d8e835d030b07177 (diff)
downloadfreebsd-ports-gnome-c629ca332e82eda8b5a46cb004983621e8b5d8d8.tar.gz
freebsd-ports-gnome-c629ca332e82eda8b5a46cb004983621e8b5d8d8.tar.zst
freebsd-ports-gnome-c629ca332e82eda8b5a46cb004983621e8b5d8d8.zip
Update to 5.1.7 beta release:
- add mysql_upgrade script to update the databases from an earlier (even minor) release
Diffstat (limited to 'databases/mysql55-server/Makefile')
-rw-r--r--databases/mysql55-server/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/databases/mysql55-server/Makefile b/databases/mysql55-server/Makefile
index 31d72dae75fb..45c2fb309c57 100644
--- a/databases/mysql55-server/Makefile
+++ b/databases/mysql55-server/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME?= mysql
-PORTVERSION= 5.1.6
-PORTREVISION?= 2
+PORTVERSION= 5.1.7
+PORTREVISION?= 0
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_MYSQL}
MASTER_SITE_SUBDIR= MySQL-5.1
PKGNAMESUFFIX?= -server
-DISTNAME= ${PORTNAME}-${PORTVERSION}-alpha
+DISTNAME= ${PORTNAME}-${PORTVERSION}-beta
MAINTAINER= ale@FreeBSD.org
COMMENT?= Multithreaded SQL database (server)
@@ -157,7 +157,7 @@ pre-fetch:
post-patch:
@${REINPLACE_CMD} -e "s|SUBDIRS =|SUBDIRS = include @docs_dirs@ @zlib_dir@ @sql_server_dirs@ @mysql_se_dirs@ @sql_server@ scripts @man_dirs@ support-files|g" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s|all: config.h|all: config.h all-local|g" ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = @server_scripts@ mysql_create_system_tables|g" ${WRKSRC}/scripts/Makefile.in
+ @${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = @server_scripts@ mysql_upgrade mysql_create_system_tables|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|dist_pkgdata_DATA =|dist_pkgdata_DATA = fill_help_tables.sql|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|man1_MANS =|man1_MANS = ${MAN1}|g" ${WRKSRC}/man/Makefile.in
@${REINPLACE_CMD} -e "s|install-data-am: install-pkgincludeHEADERS|install-data-am:|g" ${WRKSRC}/extra/Makefile.in
@@ -170,6 +170,7 @@ post-patch:
post-install:
.if !defined(PACKAGE_BUILDING)
@${SETENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${CAT} ${PKGMESSAGE}
.endif
.else