aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mysql57-server
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-12 23:08:19 +0800
committermarino <marino@FreeBSD.org>2016-09-12 23:08:19 +0800
commitb73a8ffd3ef94fb0e6a80112b86cae82ac3bd2a4 (patch)
treec3cda5dfcd7433c799f60fc476e5fbf9071b58ed /databases/mysql57-server
parent2cef4d01a46021daa3e762c2b874aa1244b4cc8d (diff)
downloadfreebsd-ports-gnome-b73a8ffd3ef94fb0e6a80112b86cae82ac3bd2a4.tar.gz
freebsd-ports-gnome-b73a8ffd3ef94fb0e6a80112b86cae82ac3bd2a4.tar.zst
freebsd-ports-gnome-b73a8ffd3ef94fb0e6a80112b86cae82ac3bd2a4.zip
databass/mysql57-server: Fix configuration of non-base SSL on all platforms
This simplifies the logic involved. Now the port will present as BROKEN if it's built on FreeBSD 9 using the base SSL library. Approved by: SSL blanket
Diffstat (limited to 'databases/mysql57-server')
-rw-r--r--databases/mysql57-server/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/databases/mysql57-server/Makefile b/databases/mysql57-server/Makefile
index c0ea514f834f..c83923409922 100644
--- a/databases/mysql57-server/Makefile
+++ b/databases/mysql57-server/Makefile
@@ -128,27 +128,21 @@ PERFSCHM_SUB_LIST+= PERFSCHEMRC=""
PERFSCHM_SUB_LIST_OFF+= PERFSCHEMRC="--skip-performance-schema"
.endif
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
### Just for the sake of FreeBSD 9.X ###
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-.if !defined(CLIENT_ONLY)
+. if !defined(CLIENT_ONLY)
EXTRA_PATCHES+= ${PATCHDIR}/rapid_plugin-patch-_x_mysqlxtest__src_mysqlxtest.cc
-.endif
-WITH_OPENSSL_PORT= yes
-CMAKE_ARGS+= -DWITH_SSL=${OPENSSLBASE}
+. endif
.endif
-.include <bsd.port.pre.mk>
-
-### FreeBSD Version > 9.X ###
-.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1000000
.if ${SSL_DEFAULT} == base
+BROKEN_FreeBSD_9= FreeBSD 9.x requires SSL from ports
CMAKE_ARGS+= -DWITH_SSL=system
.else
CMAKE_ARGS+= -DWITH_SSL=${OPENSSLBASE}
.endif
-.endif
post-extract:
@${RM} -rvf ${WRKSRC}/sql/sql_hints.yy.cc ${WRKSRC}/sql/sql_hints.yy.h