aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-BDB/Makefile
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-07-17 15:26:34 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-07-17 15:26:34 +0800
commitdafa787c5c568874033b7169f7a25ee704303140 (patch)
tree6c2b2c6e6e6661879dcddf0706d17634bbbf1bef /databases/p5-BDB/Makefile
parentb6b027f775301478daec9c0fbcacb7dd15023dbd (diff)
downloadfreebsd-ports-gnome-dafa787c5c568874033b7169f7a25ee704303140.tar.gz
freebsd-ports-gnome-dafa787c5c568874033b7169f7a25ee704303140.tar.zst
freebsd-ports-gnome-dafa787c5c568874033b7169f7a25ee704303140.zip
- Add p5-BDB 1.88
BDB is a Perl module to provide asynchronous Berkeley DB access. WWW: http://search.cpan.org/dist/BDB/
Diffstat (limited to 'databases/p5-BDB/Makefile')
-rw-r--r--databases/p5-BDB/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/databases/p5-BDB/Makefile b/databases/p5-BDB/Makefile
new file mode 100644
index 000000000000..f61077ae0c6e
--- /dev/null
+++ b/databases/p5-BDB/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-BDB
+# Date created: 2011-06-05
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= BDB
+PORTVERSION= 1.88
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MLEHMANN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Asynchronous Berkeley DB access
+
+RUN_DEPENDS= p5-common-sense>=0:${PORTSDIR}/devel/p5-common-sense
+
+CFLAGS+= -I${BDB_INCLUDE_DIR}
+MAKE_ENV= LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
+PERL_CONFIGURE= yes
+USE_BDB= 43+
+
+MAN3= BDB.3
+
+post-patch:
+ @${REINPLACE_CMD} -e '18 s|-lpthread -ldb|-l${BDB_LIB_NAME} ${PTHREAD_LIBS}|' ${WRKSRC}/Makefile.PL
+# @${REINPLACE_CMD} -e '/RPCCLIENT/d' ${WRKSRC}/BDB.pm
+
+.include <bsd.port.mk>