aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBD-Pg-13/Makefile
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2002-03-13 04:29:24 +0800
committerfjoe <fjoe@FreeBSD.org>2002-03-13 04:29:24 +0800
commit60ccd87e6c25a01774281ed67c189f6d3d437e55 (patch)
treec0a004a6b88e4a575b27e55c5c2b45c61b06eccf /databases/p5-DBD-Pg-13/Makefile
parentf6c16aac7591a4036c3daf025b7a40f0372e1752 (diff)
downloadfreebsd-ports-gnome-60ccd87e6c25a01774281ed67c189f6d3d437e55.tar.gz
freebsd-ports-gnome-60ccd87e6c25a01774281ed67c189f6d3d437e55.tar.zst
freebsd-ports-gnome-60ccd87e6c25a01774281ed67c189f6d3d437e55.zip
- allow this port to be built with PostgreSQL 7.1 port (use pg_config)
- grab maintainership
Diffstat (limited to 'databases/p5-DBD-Pg-13/Makefile')
-rw-r--r--databases/p5-DBD-Pg-13/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/databases/p5-DBD-Pg-13/Makefile b/databases/p5-DBD-Pg-13/Makefile
index 67bc13792183..f8845dbfa04d 100644
--- a/databases/p5-DBD-Pg-13/Makefile
+++ b/databases/p5-DBD-Pg-13/Makefile
@@ -12,17 +12,27 @@ MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@freebsd-services.com
+MAINTAINER= fjoe@freebsd.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-CONFIGURE_ENV+= POSTGRES_INCLUDE=${PREFIX}/include \
- POSTGRES_LIB=${PREFIX}/lib
-
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= DBD::Pg.3 DBD::dbd-pg.3
.include <bsd.port.mk>
+
+.if exists(${LOCALBASE}/bin/pg_config)
+PG_CONFIG= ${LOCALBASE}/bin/pg_config
+.elif exists(${LOCALBASE}/pgsql/bin/pg_config)
+PG_CONFIG= ${LOCALBASE}/pgsql/bin/pg_config
+.endif
+.if defined(PG_CONFIG)
+CONFIGURE_ENV+= POSTGRES_INCLUDE=`${PG_CONFIG} --includedir` \
+ POSTGRES_LIB=`${PG_CONFIG} --libdir`
+.else
+CONFIGURE_ENV+= POSTGRES_INCLUDE=${PREFIX}/include/pgsql \
+ POSTGRES_LIB=${PREFIX}/lib
+.endif