aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBD-Pg-13/Makefile
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2005-03-03 02:18:58 +0800
committermat <mat@FreeBSD.org>2005-03-03 02:18:58 +0800
commitd05d0407a29eab8b617a604c314b25ad833cf2a7 (patch)
treefe9747aefe748935fb942d7f455a811c377661a9 /databases/p5-DBD-Pg-13/Makefile
parentd31e492be08d58a62bf81b09a0fbc719bdb0d6d8 (diff)
downloadfreebsd-ports-gnome-d05d0407a29eab8b617a604c314b25ad833cf2a7.tar.gz
freebsd-ports-gnome-d05d0407a29eab8b617a604c314b25ad833cf2a7.tar.zst
freebsd-ports-gnome-d05d0407a29eab8b617a604c314b25ad833cf2a7.zip
Update to 1.40
Require at least perl 5.6
Diffstat (limited to 'databases/p5-DBD-Pg-13/Makefile')
-rw-r--r--databases/p5-DBD-Pg-13/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/databases/p5-DBD-Pg-13/Makefile b/databases/p5-DBD-Pg-13/Makefile
index 83958486c8b7..ccbeeec0a793 100644
--- a/databases/p5-DBD-Pg-13/Makefile
+++ b/databases/p5-DBD-Pg-13/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= DBD-Pg
-PORTVERSION= 1.32
-PORTREVISION= 1
+PORTVERSION= 1.40
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD
@@ -16,6 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Provides access to PostgreSQL databases through the DBI
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
USE_PGSQL= yes
PERL_CONFIGURE= yes
@@ -25,14 +27,7 @@ MAN3= DBD::Pg.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-post-patch:
- @${PERL} -i -pe '$$_ = "" if /5.006001/' \
- ${WRKSRC}/Pg.pm ${WRKSRC}/Makefile.PL
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+IGNORE= Needs DBI 1.38 which needs perl 5.6, install lang/perl5.8 and try again
.endif
PG_CONFIG= ${LOCALBASE}/bin/pg_config