aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBD-PgPP/Makefile
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2004-08-10 20:36:56 +0800
committermat <mat@FreeBSD.org>2004-08-10 20:36:56 +0800
commit73df163e497053c038b0f589a5da5ba3e8f703f1 (patch)
tree5afe219c22e7a27514744d5a82ff41973282a408 /databases/p5-DBD-PgPP/Makefile
parent5de00ac1ea30164e6e98e7415ce79f2164928c72 (diff)
downloadfreebsd-ports-gnome-73df163e497053c038b0f589a5da5ba3e8f703f1.tar.gz
freebsd-ports-gnome-73df163e497053c038b0f589a5da5ba3e8f703f1.tar.zst
freebsd-ports-gnome-73df163e497053c038b0f589a5da5ba3e8f703f1.zip
Add p5-DBD-PgPP 0.05, Pure Perl PostgreSQL driver for the DBI.
PR: ports/70229 Submitted by: Lubomir Marinov <lubomir_m@abv.bg>
Diffstat (limited to 'databases/p5-DBD-PgPP/Makefile')
-rw-r--r--databases/p5-DBD-PgPP/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/databases/p5-DBD-PgPP/Makefile b/databases/p5-DBD-PgPP/Makefile
new file mode 100644
index 000000000000..961272747281
--- /dev/null
+++ b/databases/p5-DBD-PgPP/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-DBD-PgPP
+# Date created: August 8th 2004
+# Whom: Lubomir Marinov <lubomir_m@abv.bg>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBD-PgPP
+PORTVERSION= 0.05
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lubomir_m@abv.bg
+COMMENT= Pure Perl PostgreSQL driver for the DBI
+
+PERL_CONFIGURE= yes
+
+MAN3= DBD::PgPP.3 DBD::DBD-PgPP.ja.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+post-patch:
+ @${PERL} -i -pe 's/\[:graph:\] /\\x20-\\x7e/g' ${WRKSRC}/PgPP.pm
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>