aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBD-Sybase/Makefile
diff options
context:
space:
mode:
authorsheldonh <sheldonh@FreeBSD.org>2001-05-11 01:04:49 +0800
committersheldonh <sheldonh@FreeBSD.org>2001-05-11 01:04:49 +0800
commitf2dc612a53dcafde4ca2880ff02d1d0a596297c7 (patch)
tree6da9cc741f5a957d29db068dbe4d4bfcc6c5f059 /databases/p5-DBD-Sybase/Makefile
parentfb1e039be66683ea7b8db574b56e40428191c4d7 (diff)
downloadfreebsd-ports-gnome-f2dc612a53dcafde4ca2880ff02d1d0a596297c7.tar.gz
freebsd-ports-gnome-f2dc612a53dcafde4ca2880ff02d1d0a596297c7.tar.zst
freebsd-ports-gnome-f2dc612a53dcafde4ca2880ff02d1d0a596297c7.zip
This is DBD::Sybase, a Perl5 database interface driver that uses the
FreeTDS libraries to connect to Sybase-like RDMSs, including MSSQL7.
Diffstat (limited to 'databases/p5-DBD-Sybase/Makefile')
-rw-r--r--databases/p5-DBD-Sybase/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/databases/p5-DBD-Sybase/Makefile b/databases/p5-DBD-Sybase/Makefile
new file mode 100644
index 000000000000..d86b9fdc061b
--- /dev/null
+++ b/databases/p5-DBD-Sybase/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-DBD-Sybase
+# Date created: May 10th 2001
+# Whom: Sheldon Hearn <sheldonh@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBD-Sybase
+PORTVERSION= 0.91
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sheldonh@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+LIB_DEPENDS= ct.0:${PORTSDIR}/databases/freetds \
+ intl.1:${PORTSDIR}/devel/gettext
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CONFIGURE_ENV+= SYBASE=${LOCALBASE}
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= DBD::Sybase.3
+
+.include <bsd.port.mk>