aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBD-cego
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-04-27 18:06:19 +0800
committerbapt <bapt@FreeBSD.org>2011-04-27 18:06:19 +0800
commit1225163d1bab7206a2b01c7cc8c9e3dec5a48a25 (patch)
treeb4517ade9b7db2f8f9e5e6fe002a67bd71ee3693 /databases/p5-DBD-cego
parent4090b23c0c3b961e5b0f426c14062c16b0b7fce1 (diff)
downloadfreebsd-ports-gnome-1225163d1bab7206a2b01c7cc8c9e3dec5a48a25.tar.gz
freebsd-ports-gnome-1225163d1bab7206a2b01c7cc8c9e3dec5a48a25.tar.zst
freebsd-ports-gnome-1225163d1bab7206a2b01c7cc8c9e3dec5a48a25.zip
- Fix DBD/Cego/Cego.so missing symbols
- Bump port revision PR: ports/156623 Submitted by: Kurt Jaeger <fbsd-ports _at_ opsec.eu> (maintainer)
Diffstat (limited to 'databases/p5-DBD-cego')
-rw-r--r--databases/p5-DBD-cego/Makefile1
-rw-r--r--databases/p5-DBD-cego/files/patch-makefile-pl34
2 files changed, 22 insertions, 13 deletions
diff --git a/databases/p5-DBD-cego/Makefile b/databases/p5-DBD-cego/Makefile
index 3a21b2096c41..85a5358eda8d 100644
--- a/databases/p5-DBD-cego/Makefile
+++ b/databases/p5-DBD-cego/Makefile
@@ -6,6 +6,7 @@
PORTNAME= DBD-cego
PORTVERSION= 1.1.14
+PORTRESIVION= 1
CATEGORIES= databases perl5
MASTER_SITES= http://www.lemke-it.com/
PKGNAMEPREFIX= p5-
diff --git a/databases/p5-DBD-cego/files/patch-makefile-pl b/databases/p5-DBD-cego/files/patch-makefile-pl
index 15e02a11844a..4b8fc262b300 100644
--- a/databases/p5-DBD-cego/files/patch-makefile-pl
+++ b/databases/p5-DBD-cego/files/patch-makefile-pl
@@ -1,6 +1,10 @@
---- Makefile.PL.orig 2010-09-17 10:14:49.000000000 +0200
-+++ Makefile.PL 2010-09-17 21:51:58.000000000 +0200
-@@ -29,12 +29,6 @@
+--- Makefile.PL 2010-09-17 10:14:49.000000000 +0200
++++ /tmp/bla/Makefile.PL 2011-04-24 22:00:03.000000000 +0200
+@@ -25,30 +25,21 @@
+ Getopt::Long::GetOptions(
+ $opt,
+ "help",
+- "prefix=s",
"verbose",
) || die Usage();
@@ -10,10 +14,13 @@
- die Usage();
-}
-
- use vars qw($loadlibs);
- $loadlibs= "-L" . $opt->{'prefix'} . " -llfc";
+-use vars qw($loadlibs);
+-$loadlibs= "-L" . $opt->{'prefix'} . " -llfc";
++# use vars qw($loadlibs);
++# $loadlibs= "-L/usr/local/lib";
-@@ -43,10 +37,8 @@
+ WriteMakefile(
+ 'NAME' => 'DBD::Cego',
'VERSION_FROM' => 'Cego.pm',
'PREREQ_PM' => {DBI => 1.03},
'OBJECT' => '$(O_FILES)',
@@ -21,23 +28,24 @@
- 'MYEXTLIB' => $opt->{'prefix'} . "/lib/libcego.a "
- . $opt->{'prefix'} . "/lib/liblfcxml.a "
- . $opt->{'prefix'} . "/lib/liblfc.a",
-+ 'INC' => '-I$(DBI_INSTARCH_DIR) -I/usr/local/include -I' . $opt->{'prefix'} . '/include',
-+ 'MYEXTLIB' => ' -llfc -llfcxml -lcego ',
++ 'INC' => '-I$(DBI_INSTARCH_DIR) -I/usr/local/include',
++ 'MYEXTLIB' => '-lcego -llfcxml -llfc',
"CC" => "g++",
- "LD" => "g++",
+- "LD" => "g++",
++ "LD" => "g++ -L/usr/local/lib",
"XSPROTOARG" => "-noprototypes",
-@@ -58,13 +50,7 @@
-
+ 'OPTIMIZE' => '-O6 -DNDEBUG=1',
+ 'XSOPT' => '-C++',
+@@ -59,12 +50,6 @@
sub Usage {
print STDERR <<"USAGE";
--Usage: perl $0 [options]
+ Usage: perl $0 [options]
-
-Possible options are:
-
- --prefix=<prefix path> Use <prefix> for setting up the appropriate prefix path
- to find cego libs and includes
-
-+Usage: perl $0
USAGE
exit 1;
}