aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBIWrapper
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2003-09-16 13:43:52 +0800
committererwin <erwin@FreeBSD.org>2003-09-16 13:43:52 +0800
commit11412f5f13d0ac12046d38512b9aa92faf493592 (patch)
tree83f083cfab38622b0550914a068355cf1bea6ca8 /databases/p5-DBIWrapper
parente3f2471f57b5539a0e72bb944aa8c1c159fb8431 (diff)
downloadfreebsd-ports-gnome-11412f5f13d0ac12046d38512b9aa92faf493592.tar.gz
freebsd-ports-gnome-11412f5f13d0ac12046d38512b9aa92faf493592.tar.zst
freebsd-ports-gnome-11412f5f13d0ac12046d38512b9aa92faf493592.zip
Conditionalise dependencies on databases/p5-DBI: for perl
5.005_03 use databases/p5-DBI-137 as newer versions do not support the old perl. Note that for some port, I merely removed the explicit dependency as they already have implicit dependencies via other ports. Approved by: portmgr (marcus)
Diffstat (limited to 'databases/p5-DBIWrapper')
-rw-r--r--databases/p5-DBIWrapper/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/databases/p5-DBIWrapper/Makefile b/databases/p5-DBIWrapper/Makefile
index ad702395a5e7..cc8ee414d740 100644
--- a/databases/p5-DBIWrapper/Makefile
+++ b/databases/p5-DBIWrapper/Makefile
@@ -16,8 +16,7 @@ DISTNAME= dbi_wrapper-${PORTVERSION}
MAINTAINER= petef@FreeBSD.org
COMMENT= Perl extension for generic DBI database access
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -25,4 +24,14 @@ PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= DBIWrapper.3 DBIWrapper::ResultSet.3 DBIWrapper::XMLParser.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>