aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBIx-Simple/Makefile
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-11 20:41:55 +0800
committererwin <erwin@FreeBSD.org>2005-12-11 20:41:55 +0800
commitbc9b87560507ebb81ae76139536cc5bfc6281c1d (patch)
tree1359520e898ab8396f5986e0483e968bdca7d537 /databases/p5-DBIx-Simple/Makefile
parent3121de06c7a3a3c5e811b10e3fa9bfec3f781542 (diff)
downloadfreebsd-ports-gnome-bc9b87560507ebb81ae76139536cc5bfc6281c1d.tar.gz
freebsd-ports-gnome-bc9b87560507ebb81ae76139536cc5bfc6281c1d.tar.zst
freebsd-ports-gnome-bc9b87560507ebb81ae76139536cc5bfc6281c1d.zip
DBIx::Simple module aims to be a simplified object oriented interface to Perl
DBI. From its description ... Query preparation and execution are combined in a single method, the result object (which is a wrapper around the statement handle) provides easy row-by-row and slurping methods. The "query" method returns either a result object, or a dummy object. The dummy object returns undef (or an empty list) for all methods and when used in boolean context, is false. The dummy object lets you postpone (or skip) error checking, but it also makes immediate error check simply " $db->query(...) or die $db->error". WWW: http://search.cpan.org/dist/DBIx-Simple/ PR: ports/90230 Submitted by: Parv <parv@pair.org>
Diffstat (limited to 'databases/p5-DBIx-Simple/Makefile')
-rw-r--r--databases/p5-DBIx-Simple/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Simple/Makefile b/databases/p5-DBIx-Simple/Makefile
new file mode 100644
index 000000000000..001b40271237
--- /dev/null
+++ b/databases/p5-DBIx-Simple/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: DBIx::Simple
+# Date created: 10 December 2005
+# Whom: Parv <parv@pair.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Simple
+PORTVERSION= 1.26
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= parv@pair.com
+COMMENT= Simplified object oriented interface to Perl DBI
+
+RUN_DEPENDS= p5-DBI>=1.21:${PORTSDIR}/databases/p5-DBI \
+ p5-Data-Swap>=0.02:${PORTSDIR}/devel/p5-Data-Swap
+
+.if defined(WITH_SQL_ABSTRACT)
+RUN_DEPENDS+= p5-SQL-Abstract>=0:${PORTSDIR}/databases/p5-SQL-Abstract
+.endif
+
+.if defined(WITH_DBIX_XHTML_TABLE)
+RUN_DEPENDS+= p5-DBIx-XHTML_Table>=0:${PORTSDIR}/databases/p5-DBIx-XHTML_Table
+.endif
+
+.if defined(WITH_TEXT_TABLE)
+RUN_DEPENDS+= p5-Text-Table>=0:${PORTSDIR}/textproc/p5-Text-Table
+.endif
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Simple.3 \
+ DBIx::Simple::Examples.3 \
+ DBIx::Simple::Comparison.3 \
+ DBIx::Simple::SQE.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= need at least Perl 5.6; install lang/perl or lang/perl5.8
+.endif
+
+.include <bsd.port.post.mk>