aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBIx-Tree
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2003-09-16 13:43:52 +0800
committererwin <erwin@FreeBSD.org>2003-09-16 13:43:52 +0800
commit11412f5f13d0ac12046d38512b9aa92faf493592 (patch)
tree83f083cfab38622b0550914a068355cf1bea6ca8 /databases/p5-DBIx-Tree
parente3f2471f57b5539a0e72bb944aa8c1c159fb8431 (diff)
downloadfreebsd-ports-gnome-11412f5f13d0ac12046d38512b9aa92faf493592.tar.gz
freebsd-ports-gnome-11412f5f13d0ac12046d38512b9aa92faf493592.tar.zst
freebsd-ports-gnome-11412f5f13d0ac12046d38512b9aa92faf493592.zip
Conditionalise dependencies on databases/p5-DBI: for perl
5.005_03 use databases/p5-DBI-137 as newer versions do not support the old perl. Note that for some port, I merely removed the explicit dependency as they already have implicit dependencies via other ports. Approved by: portmgr (marcus)
Diffstat (limited to 'databases/p5-DBIx-Tree')
-rw-r--r--databases/p5-DBIx-Tree/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/databases/p5-DBIx-Tree/Makefile b/databases/p5-DBIx-Tree/Makefile
index 94ea8b181e8b..34574ac1218b 100644
--- a/databases/p5-DBIx-Tree/Makefile
+++ b/databases/p5-DBIx-Tree/Makefile
@@ -15,10 +15,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= philip@p6m7g8.com
COMMENT= Perl module for generating a tree from a self-referential table
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-
PERL_CONFIGURE= yes
MAN3= DBIx::Tree.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>