aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DR-Tarantool/Makefile
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-05-25 22:41:37 +0800
committeraz <az@FreeBSD.org>2013-05-25 22:41:37 +0800
commit20fe7f7e76a05c82371182620ca4a1d413a42547 (patch)
tree4838f3cd61c86ae597ba86b05e1db4302a521d92 /databases/p5-DR-Tarantool/Makefile
parent5db4819e6beff78f3850e374e169930feb5001a4 (diff)
downloadfreebsd-ports-gnome-20fe7f7e76a05c82371182620ca4a1d413a42547.tar.gz
freebsd-ports-gnome-20fe7f7e76a05c82371182620ca4a1d413a42547.tar.zst
freebsd-ports-gnome-20fe7f7e76a05c82371182620ca4a1d413a42547.zip
This module provides a synchronous and asynchronous driver for Tarantool.
The driver does not have external dependencies, but includes the official light-weight Tarantool C client (a single C header which implements all protocol formatting) for packing requests and unpacking server responses. WWW: https://github.com/dr-co/dr-tarantool/ PR: ports/178618 Submitted by: Veniamin Gvozdikov <g.veniamin@googlemail.com>
Diffstat (limited to 'databases/p5-DR-Tarantool/Makefile')
-rw-r--r--databases/p5-DR-Tarantool/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/databases/p5-DR-Tarantool/Makefile b/databases/p5-DR-Tarantool/Makefile
new file mode 100644
index 000000000000..8f2303cfca92
--- /dev/null
+++ b/databases/p5-DR-Tarantool/Makefile
@@ -0,0 +1,30 @@
+# Created by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+# $FreeBSD$
+
+PORTNAME= DR-Tarantool
+PORTVERSION= 0.37
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:UNERA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Perl driver for Tarantool
+
+LICENSE= ART10
+
+PERL_CONFIGURE= yes
+
+MAN3= \
+ DR::README.3 \
+ DR::Tarantool.3 \
+ DR::Tarantool::AsyncClient.3 \
+ DR::Tarantool::CoroClient.3 \
+ DR::Tarantool::Iterator.3 \
+ DR::Tarantool::LLClient.3 \
+ DR::Tarantool::Spaces.3 \
+ DR::Tarantool::StartTest.3 \
+ DR::Tarantool::SyncClient.3 \
+ DR::Tarantool::Tuple.3
+
+.include <bsd.port.mk>