aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-Data-Pageset/Makefile
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-31 05:36:32 +0800
committeraaron <aaron@FreeBSD.org>2006-05-31 05:36:32 +0800
commit36724fe71dd7683e5b8da1f9bbe6eb0ba6df1b6c (patch)
tree7bfb928644278a2a389330918c4f96d014450d60 /databases/p5-Data-Pageset/Makefile
parent9d4e9c55cc0d0ad838b8efb74d1d8f661529d713 (diff)
downloadfreebsd-ports-gnome-36724fe71dd7683e5b8da1f9bbe6eb0ba6df1b6c.tar.gz
freebsd-ports-gnome-36724fe71dd7683e5b8da1f9bbe6eb0ba6df1b6c.tar.zst
freebsd-ports-gnome-36724fe71dd7683e5b8da1f9bbe6eb0ba6df1b6c.zip
Adding port databases/p5-Data-Pageset, a module for manipulating multiple pages of returned data as well as sets of pages.
Approved by: tobez (implicit)
Diffstat (limited to 'databases/p5-Data-Pageset/Makefile')
-rw-r--r--databases/p5-Data-Pageset/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/databases/p5-Data-Pageset/Makefile b/databases/p5-Data-Pageset/Makefile
new file mode 100644
index 000000000000..d7412b383c9a
--- /dev/null
+++ b/databases/p5-Data-Pageset/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Data-Pageset
+# Date created: 29 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Pageset
+PORTVERSION= 1.03
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Page numbering and page sets
+
+BUILD_DEPENDS= ${SITE_PERL}/Data/Page.pm:${PORTSDIR}/databases/p5-Data-Page
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Data::Pageset.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>