aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-Memcached-libmemcached/Makefile
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2015-07-01 09:03:03 +0800
committerswills <swills@FreeBSD.org>2015-07-01 09:03:03 +0800
commitd739ec46176e3d24940c4d0fe60799064affead0 (patch)
treee5618b15aa1d00befbb85d35d014dddab2ac25d4 /databases/p5-Memcached-libmemcached/Makefile
parentc615166c479d17da05f8fbf78bbe11d98f23e03d (diff)
downloadfreebsd-ports-gnome-d739ec46176e3d24940c4d0fe60799064affead0.tar.gz
freebsd-ports-gnome-d739ec46176e3d24940c4d0fe60799064affead0.tar.zst
freebsd-ports-gnome-d739ec46176e3d24940c4d0fe60799064affead0.zip
databases/p5-Memcached-libmemcached: improve patch
The patch to Makefile.PL needed to also replace $Config{lib_ext} (which defaults to ".a") with ".so" so that we link against the right thing. This avoids the need to patch databases/libmemcached. While here, also avoid hard coding the path to PREFIX and split out the libstdc++ to libc++ patch, avoiding duplication. Pointyhat to: swills Reported by: tijl, bapt
Diffstat (limited to 'databases/p5-Memcached-libmemcached/Makefile')
-rw-r--r--databases/p5-Memcached-libmemcached/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/databases/p5-Memcached-libmemcached/Makefile b/databases/p5-Memcached-libmemcached/Makefile
index 743f18061e50..e606dba45199 100644
--- a/databases/p5-Memcached-libmemcached/Makefile
+++ b/databases/p5-Memcached-libmemcached/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Memcached-libmemcached
PORTVERSION= 1.001801
+PORTREVISION= 1
CATEGORIES= databases devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -19,14 +20,13 @@ USE_LDCONFIG= yes
post-extract:
@${RM} -r ${WRKDIR}/src
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/Makefile.PL
+
.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD
-.if ${OSVERSION} > 1000000
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile.PL-10
-.else
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile.PL-9
-.endif
+.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1000000
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile.PL
.endif
.include <bsd.port.post.mk>