aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-RRD-Simple/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-08-05 18:53:21 +0800
committermiwi <miwi@FreeBSD.org>2006-08-05 18:53:21 +0800
commit4057a6c401aa138c6ba593351c3d959e88879c7f (patch)
tree0e64f0f062b008e9ba69a6deb7027b06c955f672 /databases/p5-RRD-Simple/Makefile
parent272d9f64eeb1dd985f3a66299a3aa06ebce8f3f7 (diff)
downloadfreebsd-ports-gnome-4057a6c401aa138c6ba593351c3d959e88879c7f.tar.gz
freebsd-ports-gnome-4057a6c401aa138c6ba593351c3d959e88879c7f.tar.zst
freebsd-ports-gnome-4057a6c401aa138c6ba593351c3d959e88879c7f.zip
RRD::Simple provides a simple interface to RRDTool's RRDs module. This
module does not currently offer fetch method that is available in the RRDs module. It does however create RRD files with a sensible set of default RRA (Round Robin Archive) definitions, and can dynamically add new data source names to an existing RRD file. This module is ideal for quick and simple storage of data within an RRD file if you do not need to, nor want to, bother defining custom RRA definitions. WWW: http://search.cpan.org/dist/RRD-Simple/ PR: ports/101073 Submitted by: chinsan <chinsan.tw(at)gmail.com> Approved by: krion (mentor)
Diffstat (limited to 'databases/p5-RRD-Simple/Makefile')
-rw-r--r--databases/p5-RRD-Simple/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/databases/p5-RRD-Simple/Makefile b/databases/p5-RRD-Simple/Makefile
new file mode 100644
index 000000000000..62e59d8e8263
--- /dev/null
+++ b/databases/p5-RRD-Simple/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: RRD-Simple
+# Date created: 2006/07/21
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= RRD-Simple
+PORTVERSION= 1.39
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/N/NI/NICOLAW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Simple interface to create and store data in RRD files
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Deep.pm:${PORTSDIR}/devel/p5-Test-Deep \
+ p5-Test-Pod>=0.90:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>0:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
+ ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/net/rrdtool
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+MAN3= RRD::Simple.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or higher. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>