aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-Search-Xapian/Makefile
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2006-03-27 04:52:53 +0800
committersem <sem@FreeBSD.org>2006-03-27 04:52:53 +0800
commit6a3d49f016bb5e18b6a16ddcc9d7e63816b1a895 (patch)
tree16bfb7e7dc4de77857dd86f08c193531855d3de2 /databases/p5-Search-Xapian/Makefile
parent02de919daeca7434460633eff6cadfc094abee9f (diff)
downloadfreebsd-ports-gnome-6a3d49f016bb5e18b6a16ddcc9d7e63816b1a895.tar.gz
freebsd-ports-gnome-6a3d49f016bb5e18b6a16ddcc9d7e63816b1a895.tar.zst
freebsd-ports-gnome-6a3d49f016bb5e18b6a16ddcc9d7e63816b1a895.zip
This module wraps most methods of most Xapian classes.
WWW: http://search.cpan.org/dist/Search-Xapian/ PR: ports/93707 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
Diffstat (limited to 'databases/p5-Search-Xapian/Makefile')
-rw-r--r--databases/p5-Search-Xapian/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/databases/p5-Search-Xapian/Makefile b/databases/p5-Search-Xapian/Makefile
new file mode 100644
index 000000000000..a3eaa966284c
--- /dev/null
+++ b/databases/p5-Search-Xapian/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: databases/p5-Search-Xapian
+# Date created: Feb 22 2006
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Search-Xapian
+PORTVERSION= 0.9.2.3
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Search
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Perl XS frontend to the Xapian C++ search library
+
+BUILD_DEPENDS= xapian-core>=0:${PORTSDIR}/databases/xapian-core
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CC= ${CXX}
+
+MAN3= Search::Xapian.3 \
+ Search::Xapian::BM25Weight.3 \
+ Search::Xapian::BoolWeight.3 \
+ Search::Xapian::Database.3 \
+ Search::Xapian::Document.3 \
+ Search::Xapian::Enquire.3 \
+ Search::Xapian::PositionIterator.3 \
+ Search::Xapian::PostingIterator.3 \
+ Search::Xapian::QueryParser.3 \
+ Search::Xapian::Stem.3 \
+ Search::Xapian::TermIterator.3 \
+ Search::Xapian::Weight.3 \
+ Search::Xapian::WritableDatabase.3
+
+.include <bsd.port.mk>