aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-Test-postgresql/Makefile
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-12-26 23:10:20 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-12-26 23:10:20 +0800
commita62df56cb7c070e3bd03551952d36541c336159a (patch)
tree4dc1c58073edde9dbf5bd30be36fb0f62fe0346c /databases/p5-Test-postgresql/Makefile
parent5fcdc1e51c3e08d410e61f99135f499be4be132f (diff)
downloadfreebsd-ports-gnome-a62df56cb7c070e3bd03551952d36541c336159a.tar.gz
freebsd-ports-gnome-a62df56cb7c070e3bd03551952d36541c336159a.tar.zst
freebsd-ports-gnome-a62df56cb7c070e3bd03551952d36541c336159a.zip
Test::postgresql automatically setups a postgresql instance in a
temporary directory, and destroys it when the perl script exits. WWW: http://search.cpan.org/dist/Test-postgresql/
Diffstat (limited to 'databases/p5-Test-postgresql/Makefile')
-rw-r--r--databases/p5-Test-postgresql/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/databases/p5-Test-postgresql/Makefile b/databases/p5-Test-postgresql/Makefile
new file mode 100644
index 000000000000..47d3b0e2cf0b
--- /dev/null
+++ b/databases/p5-Test-postgresql/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Test::postgresql
+# Date created: 26 Dec 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-postgresql
+PORTVERSION= 0.09
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension of postgresql runner for tests
+
+RUN_DEPENDS= \
+ p5-Class-Accessor-Lite>0:${PORTSDIR}/devel/p5-Class-Accessor-Lite \
+ p5-DBI>0:${PORTSDIR}/databases/p5-DBI \
+ p5-DBD-Pg>0:${PORTSDIR}/databases/p5-DBD-Pg
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::postgresql.3
+
+.include <bsd.port.mk>