aboutsummaryrefslogtreecommitdiffstats
path: root/databases/percona55-server/Makefile
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2005-04-11 17:31:05 +0800
committerale <ale@FreeBSD.org>2005-04-11 17:31:05 +0800
commit39273435fea56472416bf65caa4729121e22e6e7 (patch)
tree2cb889caa4060375b69946fdacb30abc1887ad6b /databases/percona55-server/Makefile
parent2982210e6d53639f3b94eb31555cd353d7b0887b (diff)
downloadfreebsd-ports-gnome-39273435fea56472416bf65caa4729121e22e6e7.tar.gz
freebsd-ports-gnome-39273435fea56472416bf65caa4729121e22e6e7.tar.zst
freebsd-ports-gnome-39273435fea56472416bf65caa4729121e22e6e7.zip
- Use the rcNG script to kill MySQL on deinstallation [1]
- Set the new sequence for finding my.cnf files [2]: /etc, ${PREFIX}/etc, ${mysql_dbdir} (default to: /etc/my.cnf, /usr/local/etc/my.cnf, /var/db/mysql/my.cnf) PR: ports/79166 [1], ports/79597 [2] Submitted by: Sergey Prikhodko <sergey@network-asp.biz> [1], Vasil Dimov <vd@datamax.bg> [2]
Diffstat (limited to 'databases/percona55-server/Makefile')
-rw-r--r--databases/percona55-server/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/databases/percona55-server/Makefile b/databases/percona55-server/Makefile
index 4ba0f5b35d05..60ffb43d3df0 100644
--- a/databases/percona55-server/Makefile
+++ b/databases/percona55-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= mysql
PORTVERSION= 5.0.3
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_MYSQL}
MASTER_SITE_SUBDIR= MySQL-5.0
@@ -153,6 +153,7 @@ post-patch:
@${REINPLACE_CMD} -e "s|dist_pkgdata_DATA =|dist_pkgdata_DATA = fill_help_tables.sql|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|man_MANS =|man_MANS = ${MAN1}|g" ${WRKSRC}/man/Makefile.in
@${REINPLACE_CMD} -e "s|install-data-am: install-pkgincludeHEADERS|install-data-am:|g" ${WRKSRC}/include/Makefile.in
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/mysys/default.c
.if defined(WITH_PROC_SCOPE_PTH)
@${REINPLACE_CMD} -e "s|PTHREAD_SCOPE_SYSTEM|PTHREAD_SCOPE_PROCESS|g" ${WRKSRC}/sql/mysqld.cc
.endif
@@ -189,6 +190,7 @@ post-patch:
@${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = mysql_config mysql_fix_privilege_tables mysqlbug|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|dist_pkgdata_DATA =|dist_pkgdata_DATA = mysql_fix_privilege_tables.sql|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|man_MANS =|man_MANS = ${MAN1}|g" ${WRKSRC}/man/Makefile.in
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/mysys/default.c
.if defined(WITH_PROC_SCOPE_PTH)
@${REINPLACE_CMD} -e "s|PTHREAD_SCOPE_SYSTEM|PTHREAD_SCOPE_PROCESS|g" ${WRKSRC}/tools/mysqlmanager.c
.endif