aboutsummaryrefslogtreecommitdiffstats
path: root/databases/pgbash
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-12-29 13:20:14 +0800
committeredwin <edwin@FreeBSD.org>2003-12-29 13:20:14 +0800
commit86dd730f8c10bc42fdd7e491ac08b8b427d804bd (patch)
tree5b5800c91f5e704247c78bc9619d3f6f473a38a0 /databases/pgbash
parentc48db0d7390011d625d04db3e1d61b655e191a3b (diff)
downloadfreebsd-ports-gnome-86dd730f8c10bc42fdd7e491ac08b8b427d804bd.tar.gz
freebsd-ports-gnome-86dd730f8c10bc42fdd7e491ac08b8b427d804bd.tar.zst
freebsd-ports-gnome-86dd730f8c10bc42fdd7e491ac08b8b427d804bd.zip
New port: databases/pgbash
pgBash is a bash shell with the ability to directly connect to a PostgreSQL Database and use it while still being at a shell prompt with all its features. PR: ports/54271 Submitted by: Sascha Holzleiter <sascha@root-login.org>
Diffstat (limited to 'databases/pgbash')
-rw-r--r--databases/pgbash/Makefile49
-rw-r--r--databases/pgbash/distinfo2
-rw-r--r--databases/pgbash/pkg-descr4
-rw-r--r--databases/pgbash/pkg-plist2
4 files changed, 57 insertions, 0 deletions
diff --git a/databases/pgbash/Makefile b/databases/pgbash/Makefile
new file mode 100644
index 000000000000..a1fe546b9857
--- /dev/null
+++ b/databases/pgbash/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: pgbash
+# Date created: 6 July 2003
+# Whom: Sascha Holzleiter <sascha@root-login.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pgbash
+PORTVERSION= 7.3
+CATEGORIES= databases
+MASTER_SITES= http://www.psn.co.jp/PostgreSQL/pgbash/:pgsource \
+ ${MASTER_SITE_GNU:S/$/:bashsrc/}
+MASTER_SITE_SUBDIR= bash/:bashsrc
+DISTFILES= pgbash-7.3.tar.gz:pgsource \
+ bash-2.05a.tar.gz:bashsrc
+EXTRACT_ONLY= pgbash-7.3.tar.gz
+
+MAINTAINER= sascha@root-login.org
+COMMENT= SQL Bash Shell for PostgreSQL
+
+LIB_DEPENDS= pq.3:${PORTSDIR}/databases/postgresql-client
+
+WRKSRC= ${WRKDIR}/pgbash-7.3/src/bash-2.05a
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+post-extract:
+ ${ECHO_MSG} ">>> extracting bash"
+ ${TAR} -C ${WRKDIR}/pgbash-7.3/src -xzf ${DISTDIR}/bash-2.05a.tar.gz
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's|/etc/pgbashrc|${PREFIX}/etc/pgbashrc|g' \
+ ${WRKDIR}/pgbash-7.3/src/bash-2.05a-patch/shell.c.patch
+.for i in Makefile.in.patch builtins-Makefile.in.patch \
+ builtins-declare.def.patch builtins-mkbuilrins.c.patch \
+ builtins-set.def.patch builtins-setattr.def.patch configure.in.patch \
+ configure.patch parse.y.patch shell.c.patch variables.c.patch
+ ${PATCH} -d ${WRKSRC} -p1 < ${WRKDIR}/pgbash-7.3/src/bash-2.05a-patch/${i}
+.endfor
+
+do-configure:
+ cd ${WRKSRC}; ./configure --pginc-prefix=${LOCALBASE}/include --pglib-prefix=${LOCALBASE}/lib
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pgbash ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKDIR}/pgbash-7.3/rc/pgbashrc ${PREFIX}/etc/pgbashrc-dist
+
+.include <bsd.port.mk>
diff --git a/databases/pgbash/distinfo b/databases/pgbash/distinfo
new file mode 100644
index 000000000000..7d9b7c2d47f6
--- /dev/null
+++ b/databases/pgbash/distinfo
@@ -0,0 +1,2 @@
+MD5 (pgbash-7.3.tar.gz) = e3e33423208a5a538708dc92001abf67
+MD5 (bash-2.05a.tar.gz) = eeabc3f624861c4a8a687f7701db3d06
diff --git a/databases/pgbash/pkg-descr b/databases/pgbash/pkg-descr
new file mode 100644
index 000000000000..92551968d6a0
--- /dev/null
+++ b/databases/pgbash/pkg-descr
@@ -0,0 +1,4 @@
+pgBash is a bash shell with builtin SQL features
+for PostgreSQL
+
+WWW: http://www.psn.co.jp/PostgreSQL/pgbash/
diff --git a/databases/pgbash/pkg-plist b/databases/pgbash/pkg-plist
new file mode 100644
index 000000000000..1edab1d3e4e3
--- /dev/null
+++ b/databases/pgbash/pkg-plist
@@ -0,0 +1,2 @@
+bin/pgbash
+etc/pgbashrc-dist