aboutsummaryrefslogtreecommitdiffstats
path: root/databases/pgtop/Makefile
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2006-05-31 20:36:20 +0800
committervd <vd@FreeBSD.org>2006-05-31 20:36:20 +0800
commitdbe06de1c5422d4087dd37cb2f8cdeaaffedae5a (patch)
tree374daf95c4accc17716946ccb0a796757b6187f9 /databases/pgtop/Makefile
parent4c321cb979d1a8f2eb9ee06234d57329a1485b7b (diff)
downloadfreebsd-ports-gnome-dbe06de1c5422d4087dd37cb2f8cdeaaffedae5a.tar.gz
freebsd-ports-gnome-dbe06de1c5422d4087dd37cb2f8cdeaaffedae5a.tar.zst
freebsd-ports-gnome-dbe06de1c5422d4087dd37cb2f8cdeaaffedae5a.zip
Add new port databases/pgtop - Display PostgreSQL performance info like top(1)
pgtop was inspired by mytop (http://mytop.sourceforge.net/ [1]), which in turn was inspired by the system monitoring tool top. pgtop will connect to a PostgreSQL server and periodically run queries against the pg_stat* relations and attempt to summarize the information from them in a useful format. http://search.cpan.org/~cosimo/pgtop-0.04/pgtop [1] this site is not available, the correct one is: http://jeremy.zawodny.com/mysql/mytop/ PR: ports/98204 Submitted by: r@robakdesign.com <r@valinor.amu.edu.pl>
Diffstat (limited to 'databases/pgtop/Makefile')
-rw-r--r--databases/pgtop/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/databases/pgtop/Makefile b/databases/pgtop/Makefile
new file mode 100644
index 000000000000..f30750966d05
--- /dev/null
+++ b/databases/pgtop/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: pgtop
+# Date created: 30 May 2006
+# Whom: Bartek Rutkowski <r@robakdesign.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pgtop
+PORTVERSION= 0.04
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/C/CO/COSIMO
+
+MAINTAINER= r@robakdesign.com
+COMMENT= Display PostgreSQL performance info like top(1)
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg \
+ ${SITE_PERL}/${PERL_ARCH}/Bundle/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor \
+ ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long
+
+PERL_CONFIGURE= yes
+
+MAN1= pgtop.1
+
+.include <bsd.port.mk>