aboutsummaryrefslogtreecommitdiffstats
path: root/databases/pgtune
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-10-19 22:50:52 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-10-19 22:50:52 +0800
commit6a98fceb0a6004a4c5a1fd86d54347f6a29f74c4 (patch)
tree72fd93ae39b43490b34dc8479465e07b453d126e /databases/pgtune
parente18413661fadcae47bb20ec0de548623410227ad (diff)
downloadfreebsd-ports-gnome-6a98fceb0a6004a4c5a1fd86d54347f6a29f74c4.tar.gz
freebsd-ports-gnome-6a98fceb0a6004a4c5a1fd86d54347f6a29f74c4.tar.zst
freebsd-ports-gnome-6a98fceb0a6004a4c5a1fd86d54347f6a29f74c4.zip
Improve shebangfix framework
- Support multiple values in *_OLD_CMD, i.e. we can now fix both "/usr/bin/python" and "/usr/bin/env python" at the same time - Default *_OLD_CMD values are now always appended, so you don't need to specify them in individual ports - Add lua support (depends on USES=lua) - Add more default values, such as "/usr/bin/env foo" for python, perl, bash, ruby and lua - Shebangfix now matches whole words, e.g. we will no longer (erroneously) replace "/usr/bin/perl5.005" with "${perl_CMD}5.005" (but "/usr/bin/perl -tt" is still (correctly) replaced with "${perl_CMD} -tt") Note that *_OLD_CMD items containing spaces must now be quoted (e.g. perl_OLD_CMD=/bin/perl /usr/bin/perl "/usr/bin/env perl") Update shebangfix usage according to new rules in many ports: - Remove *_OLD_CMD for patterns now replaced by default - Quote custom *_OLD_CMD which contain spaces Fix shebangfix usage in many ports (irrelevant to infrastructure change): - Remove redundant SHEBANG_LANG (no need to duplicate default langs) - Remove redundant *_CMD (such as python_CMD=${LOCALBASE}/bin/python${PYTHON_VER} when USES=python is present) - Never use *_OLD_CMD in REINPLACE_CMD matchers, these should always look for exact string Approved by: portmgr (bapt) Differential Revision: D3756
Diffstat (limited to 'databases/pgtune')
-rw-r--r--databases/pgtune/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/databases/pgtune/Makefile b/databases/pgtune/Makefile
index 8d978fa1780b..1884eb9b49ae 100644
--- a/databases/pgtune/Makefile
+++ b/databases/pgtune/Makefile
@@ -12,17 +12,11 @@ MAINTAINER= gjb@FreeBSD.org
COMMENT= Postgresql.conf tuning tips based on hardware and load type
USES= python shebangfix
-NO_BUILD= yes
-
SHEBANG_FILES= ${PORTNAME}
-python_OLD_CMD= ${PREFIX}/bin/python
-
-pre-install:
- @${REINPLACE_CMD} -e 's|${python_OLD_CMD}|${PYTHON_CMD}|' \
- ${WRKSRC}/${PORTNAME}
+NO_BUILD= yes
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/pgtune ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/pgtune ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${PREFIX}/share/pgtune/settings
${INSTALL_DATA} ${WRKSRC}/pg_settings* \
${STAGEDIR}${PREFIX}/share/pgtune/settings