aboutsummaryrefslogtreecommitdiffstats
path: root/databases/php5-oci8
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-07-11 21:21:54 +0800
committergarga <garga@FreeBSD.org>2006-07-11 21:21:54 +0800
commit2d0b867580c286b76ee7324646574b079b02217a (patch)
tree160c148efb22bb191acddf37728da57b4789a0df /databases/php5-oci8
parent66bc0685445b09177ea0450573017174f80b670c (diff)
downloadfreebsd-ports-gnome-2d0b867580c286b76ee7324646574b079b02217a.tar.gz
freebsd-ports-gnome-2d0b867580c286b76ee7324646574b079b02217a.tar.zst
freebsd-ports-gnome-2d0b867580c286b76ee7324646574b079b02217a.zip
Add databases/php5-oci8:
This port adds support for OCI8 PHP shared extension. It replaces the old Oracle shared extension which is obsolete and will be dropped (moved to PECL) in PHP 5.1. This patch also corrects dependency for the Oracle shared extension (added Oracle client in RUN_DEPENDS). PR: ports/86580 Submitted by: Simun Mikecin <numisemis at yahoo.com>
Diffstat (limited to 'databases/php5-oci8')
-rw-r--r--databases/php5-oci8/Makefile13
-rw-r--r--databases/php5-oci8/files/patch-config.m412
2 files changed, 25 insertions, 0 deletions
diff --git a/databases/php5-oci8/Makefile b/databases/php5-oci8/Makefile
new file mode 100644
index 000000000000..e60a802b9757
--- /dev/null
+++ b/databases/php5-oci8/Makefile
@@ -0,0 +1,13 @@
+# New ports collection makefile for: php5-oci8
+# Date created: 24 Sep 2004
+# Whom: Simun Mikecin <numisemis@yahoo.com>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= databases
+PKGNAMESUFFIX= -oci8
+
+MASTERDIR= ${.CURDIR}/../../lang/php5
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php5-oci8/files/patch-config.m4 b/databases/php5-oci8/files/patch-config.m4
new file mode 100644
index 000000000000..d504cdf1c1bb
--- /dev/null
+++ b/databases/php5-oci8/files/patch-config.m4
@@ -0,0 +1,12 @@
+--- config.m4.orig Wed Apr 5 11:06:00 2006
++++ config.m4 Tue Jul 11 08:20:27 2006
+@@ -177,8 +177,7 @@
+ ;;
+
+ 8.1)
+- PHP_ADD_LIBRARY(clntsh, 1, OCI8_SHARED_LIBADD)
+- PHP_ADD_LIBPATH($OCI8_DIR/$OCI8_LIB_DIR, OCI8_SHARED_LIBADD)
++ PHP_ADD_LIBRARY_WITH_PATH(oci8, ., OCI8_SHARED_LIBADD)
+
+ PHP_CHECK_LIBRARY(clntsh, OCIEnvCreate,
+ [