aboutsummaryrefslogtreecommitdiffstats
path: root/databases/php5-tarantool
diff options
context:
space:
mode:
authorvg <vg@FreeBSD.org>2013-10-31 21:10:58 +0800
committervg <vg@FreeBSD.org>2013-10-31 21:10:58 +0800
commitd79a5319b56ca87ff652d64d4a8e582755aa56ca (patch)
tree345aeee33cee02aada8a99eb09f4a2d959004b22 /databases/php5-tarantool
parent19734cad99a00e022eb56ce4889cf8f5a0549093 (diff)
downloadfreebsd-ports-gnome-d79a5319b56ca87ff652d64d4a8e582755aa56ca.tar.gz
freebsd-ports-gnome-d79a5319b56ca87ff652d64d4a8e582755aa56ca.tar.zst
freebsd-ports-gnome-d79a5319b56ca87ff652d64d4a8e582755aa56ca.zip
databases/php5-tarantool PECL PHP driver for Tarantool/Box
PECL PHP driver for Tarantool/Box WWW: https://github.com/tarantool/tarantool-php PR: ports/178614 Submitted by: myself Approved by: eadler, osa, rm (mentors, implicit)
Diffstat (limited to 'databases/php5-tarantool')
-rw-r--r--databases/php5-tarantool/Makefile31
-rw-r--r--databases/php5-tarantool/distinfo2
-rw-r--r--databases/php5-tarantool/pkg-descr3
3 files changed, 36 insertions, 0 deletions
diff --git a/databases/php5-tarantool/Makefile b/databases/php5-tarantool/Makefile
new file mode 100644
index 000000000000..7742bae763cb
--- /dev/null
+++ b/databases/php5-tarantool/Makefile
@@ -0,0 +1,31 @@
+# Created by: Veniamin Gvozdikov <vg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= tarantool
+PORTVERSION= ${TR_VER}
+CATEGORIES= databases
+MASTER_SITES= GH GHC
+PKGNAMEPREFIX= php5-
+DISTFILES= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= vg@FreeBSD.org
+COMMENT= PECL PHP driver for Tarantool/Box
+
+USE_GITHUB= yes
+USE_PHP= yes
+USE_PHPEXT= yes
+USE_PHPIZE= yes
+DEFAULT_PHP_VER=5
+
+PHP_MODNAME= ${PORTNAME}
+GH_PROJECT= ${PORTNAME}-php
+GH_ACCOUNT= tarantool
+GH_COMMIT= d88ac7b
+GH_TAGNAME= ${GH_COMMIT}
+TR_VER= 20131031
+
+CONFIGURE_ARGS+= --with-tarantool
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>
diff --git a/databases/php5-tarantool/distinfo b/databases/php5-tarantool/distinfo
new file mode 100644
index 000000000000..68938a88053a
--- /dev/null
+++ b/databases/php5-tarantool/distinfo
@@ -0,0 +1,2 @@
+SHA256 (php5-tarantool-20131031.tar.gz) = 3671e3c134de0fa225199afca9414931e8b0773b3ffa04f501c71cbc52ff21b2
+SIZE (php5-tarantool-20131031.tar.gz) = 21000
diff --git a/databases/php5-tarantool/pkg-descr b/databases/php5-tarantool/pkg-descr
new file mode 100644
index 000000000000..9aa49257161f
--- /dev/null
+++ b/databases/php5-tarantool/pkg-descr
@@ -0,0 +1,3 @@
+PECL PHP driver for Tarantool/Box
+
+WWW: https://github.com/tarantool/tarantool-php