aboutsummaryrefslogtreecommitdiffstats
path: root/databases/phpmyadmin/Makefile
diff options
context:
space:
mode:
authornbm <nbm@FreeBSD.org>2001-01-19 20:53:37 +0800
committernbm <nbm@FreeBSD.org>2001-01-19 20:53:37 +0800
commit1aeae20168751de31384141ae577a880393debc1 (patch)
treec1369e42a202a9da7133b3eba6418071b371a637 /databases/phpmyadmin/Makefile
parent168145daae6f2683de18795197d7b7b122dd8bb2 (diff)
downloadfreebsd-ports-gnome-1aeae20168751de31384141ae577a880393debc1.tar.gz
freebsd-ports-gnome-1aeae20168751de31384141ae577a880393debc1.tar.zst
freebsd-ports-gnome-1aeae20168751de31384141ae577a880393debc1.zip
Add phpMyAdmin, a set of PHP3 scripts to adminstrate MySQL over the web
Diffstat (limited to 'databases/phpmyadmin/Makefile')
-rw-r--r--databases/phpmyadmin/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/databases/phpmyadmin/Makefile b/databases/phpmyadmin/Makefile
new file mode 100644
index 000000000000..35c85927900a
--- /dev/null
+++ b/databases/phpmyadmin/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: phpMyAdmin
+# Date created: 19 Jan 2001
+# Whom: nbm
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpmyadmin
+PORTVERSION= 2.1.0
+CATEGORIES= databases www
+MASTER_SITES= http://phpwizard.net/projects/phpMyAdmin/
+DISTNAME= phpMyAdmin_${PORTVERSION}
+
+MAINTAINER= nbm@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/mysql/libmysqlclient.so:${PORTSDIR}/databases/mysql322-client
+.if defined(WITH_PHP4)
+BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/www/mod_php3
+.endif
+
+WRKSRC= ${WRKDIR}/phpMyAdmin
+NO_BUILD= YES
+
+do-install:
+ ${MKDIR} ${PREFIX}/www/data.default/phpMyAdmin/
+ ${CP} -R ${WRKSRC}/* ${PREFIX}/www/data.default/phpMyAdmin/
+
+.include <bsd.port.mk>