aboutsummaryrefslogtreecommitdiffstats
path: root/databases/phpmyadmin
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-10-12 09:06:15 +0800
committeredwin <edwin@FreeBSD.org>2004-10-12 09:06:15 +0800
commit9e54a18b7aa64a76cd57ad7d93697744fc940ff6 (patch)
tree0452910cd540f3c02fb53e327bb55282f082e388 /databases/phpmyadmin
parentb2dc380c78a4430158fa68710e038aa237e027db (diff)
downloadfreebsd-ports-gnome-9e54a18b7aa64a76cd57ad7d93697744fc940ff6.tar.gz
freebsd-ports-gnome-9e54a18b7aa64a76cd57ad7d93697744fc940ff6.tar.zst
freebsd-ports-gnome-9e54a18b7aa64a76cd57ad7d93697744fc940ff6.zip
[ Maintainer Update ] databases/phpmyadmin to 2.6.0
- Update to phpMyAdmin 2.6.0 - Add OPTIONS support (From 71100) - Add MySQLi support PR: ports/72143 Submitted by: Matthew Seaman <m.seaman@infracaninophile.co.uk>
Diffstat (limited to 'databases/phpmyadmin')
-rw-r--r--databases/phpmyadmin/Makefile42
-rw-r--r--databases/phpmyadmin/distinfo4
-rw-r--r--databases/phpmyadmin/pkg-descr31
3 files changed, 57 insertions, 20 deletions
diff --git a/databases/phpmyadmin/Makefile b/databases/phpmyadmin/Makefile
index 553d7a39d865..d1966e949b4f 100644
--- a/databases/phpmyadmin/Makefile
+++ b/databases/phpmyadmin/Makefile
@@ -6,21 +6,22 @@
#
PORTNAME= phpMyAdmin
-PORTVERSION= 2.5.7.1
-PORTREVISION= 1
+PORTVERSION= 2.6.0
CATEGORIES= databases www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= phpmyadmin
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.(.)$/-pl\1/}
MAINTAINER= m.seaman@infracaninophile.co.uk
-COMMENT= A set of PHP-scripts to administer MySQL over the web
+COMMENT= A set of PHP-scripts to manage MySQL over the web
USE_BZIP2= yes
NO_BUILD= yes
-USE_PHP= bz2 gd mysql openssl pcre pdf zlib
+USE_PHP= mysql pcre
-.if defined(WITH_SUPHP)
+# Unfortunately can't make WITH_SUPHP part of the OPTIONS selection,
+# since it has to be processed before just about anything else.
+
+.if defined(WITH_SUPHP) && !defined(WITHOUT_SUPHP)
PKGNAMESUFFIX= -suphp
RUN_DEPENDS+= ${LOCALBASE}/sbin/suphp:${PORTSDIR}/www/suphp
@@ -43,6 +44,30 @@ WANT_PHP_WEB= yes
.endif
+# Copy the way lang/php{4,5}-extensions deals with its OPTIONS -- avoids
+# problems with include of bsd.port.pre.mk
+
+OPTIONS= BZ2 "bzip2 library support" on \
+ GD "GD library support" on \
+ MYSQLI "Improved MySQL support (PHP5, MySQL 4.1 only)" off \
+ OPENSSL "OpenSSL support" on \
+ PDF "PDFlib support (implies GD)" on \
+ ZLIB "ZLIB support" on
+
+PORT_DBDIR?= /var/db/ports
+LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
+OPTIONSFILE?= ${PORT_DBDIR}/${LATEST_LINK}/options
+
+.if exists(${OPTIONSFILE})
+.include "${OPTIONSFILE}"
+.endif
+
+.for opt in BZ2 GD MYSQLI OPENSSL PDF ZLIB
+. if !defined(WITHOUT_${opt}) || defined(WITH_${opt})
+USE_PHP+= ${opt:L}
+. endif
+.endfor
+
MSG_SKEL= ${PKGDIR}/pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -56,9 +81,12 @@ PLIST_SUB+= MYADMDIR=${MYADMDIR} MYADMGRP=${MYADMGRP}
.SILENT:
+do-build:
+ @${DO_NADA}
+
pre-everything::
${ECHO_MSG} ""
- ${ECHO_MSG} "You may use the following build options:"
+ ${ECHO_MSG} "You may use the following additional build option:"
${ECHO_MSG} ""
${ECHO_MSG} " WITH_SUPHP=yes Install appropriately for use with"
${ECHO_MSG} " the www/suphp port [default: no]"
diff --git a/databases/phpmyadmin/distinfo b/databases/phpmyadmin/distinfo
index 795fe5ba0784..c920be3d3797 100644
--- a/databases/phpmyadmin/distinfo
+++ b/databases/phpmyadmin/distinfo
@@ -1,2 +1,2 @@
-MD5 (phpMyAdmin-2.5.7-pl1.tar.bz2) = 93b7c7f3dfcfd6df9c2ea26f31a51772
-SIZE (phpMyAdmin-2.5.7-pl1.tar.bz2) = 1123591
+MD5 (phpMyAdmin-2.6.0.tar.bz2) = 7d8dc68a88aca0c5f36c5d8996bb563f
+SIZE (phpMyAdmin-2.6.0.tar.bz2) = 1277016
diff --git a/databases/phpmyadmin/pkg-descr b/databases/phpmyadmin/pkg-descr
index c89033172805..b1d2973e53c8 100644
--- a/databases/phpmyadmin/pkg-descr
+++ b/databases/phpmyadmin/pkg-descr
@@ -1,15 +1,24 @@
-phpMyAdmin is intended to handle the adminstration of MySQL over the web.
+phpMyAdmin is intended to handle the administration of MySQL over the
+Web. It can manage a whole MySQL server as well as a single database.
+
Currently it can:
- - create and drop databases
- - create, copy, drop and alter tables
- - delete, edit and add fields
- - execute any SQL-statement, even batch-queries
- - manage keys on fields
- - load text files into tables
- - create and read dumps of tables
- - export and import CSV data
- - administer multiple servers and single databases
- - communicate in more than 38 different languages
+ - create and drop databases
+ - create, copy, drop, rename and alter tables
+ - do table maintenance
+ - delete, edit and add fields
+ - execute any SQL-statement, even batch-queries
+ - manage keys on fields
+ - load text files into tables
+ - create and read dumps of tables
+ - export data to CSV, XML and Latex formats
+ - administer multiple servers
+ - manage MySQL users and privileges
+ - check referential integrity
+ - using Query-by-example (QBE), create complex queries automatically
+ connecting required tables
+ - create PDF graphics of your Database layout
+ - search globally in a database or a subset of it
+ - communicate in 47 different languages
WWW: http://www.phpmyadmin.net/