aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgis
diff options
context:
space:
mode:
authorgirgen <girgen@FreeBSD.org>2005-01-31 08:35:55 +0800
committergirgen <girgen@FreeBSD.org>2005-01-31 08:35:55 +0800
commitca9d0e2291f677879c1b36a416eb2ad271850cbc (patch)
tree339f4530a6f0b38252173ddc8ba47c21226501d3 /databases/postgis
parentcbe074a01a678ad3149123153f48962b4b035576 (diff)
downloadfreebsd-ports-gnome-ca9d0e2291f677879c1b36a416eb2ad271850cbc.tar.gz
freebsd-ports-gnome-ca9d0e2291f677879c1b36a416eb2ad271850cbc.tar.zst
freebsd-ports-gnome-ca9d0e2291f677879c1b36a416eb2ad271850cbc.zip
Split the postgresql ports into a server and a client part.
All ports depending on postgresql shall use the USE_PGSQL=yes knob defined in Mk/bsd.ports.mk. Bumping portrevisions where needed. PR: 75344 Approved by: portmgr@ (kris), ade & sean (mentors)
Diffstat (limited to 'databases/postgis')
-rw-r--r--databases/postgis/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/databases/postgis/Makefile b/databases/postgis/Makefile
index 1293fcd0f10e..9fe5ffa657d5 100644
--- a/databases/postgis/Makefile
+++ b/databases/postgis/Makefile
@@ -27,8 +27,9 @@ PGSQL_SRC= ${WRKDIR}/pgsql/postgresql
INSTALL_TARGET= install
INSTALLS_SHLIB= no
-OPTIONS= PGSQL8 "Use PostgreSQL 8 instead of PostgreSQL 7.4" off \
- GEOS "Include GEOS - the OpenGIS 'Simple Features for SQL'" off \
+OPTIONS= GEOS "Include GEOS - the OpenGIS 'Simple Features for SQL'" off \
+
+USE_PGSQL= YES
.include <bsd.port.pre.mk>
@@ -37,13 +38,7 @@ MAKE_ARGS= PGSQL_SRC="${PGSQL_SRC}" \
BINDIR="${PREFIX}/bin" \
LIBDIR="${PREFIX}/lib"
-.if defined(WITH_PGSQL8)
-PGSQL_PORTDIR= ${PORTSDIR}/databases/postgresql-devel
-.else
-PGSQL_PORTDIR= ${PORTSDIR}/databases/postgresql7
-.endif
-
-LIB_DEPENDS+= pq.3:${PGSQL_PORTDIR}
+PGSQL_PORTDIR= ${PORTSDIR}/databases/postgresql${PGSQL_VER}-client
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \