aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql-contrib/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-08-24 20:17:02 +0800
committeredwin <edwin@FreeBSD.org>2003-08-24 20:17:02 +0800
commite7d47e44fc430bb42420db312b96517db4cea8c7 (patch)
treeb2025a66a06158790b09eb40a937138e62450e02 /databases/postgresql-contrib/Makefile
parent2c01b9323abe369eadbf49038ba15a52bd547883 (diff)
downloadfreebsd-ports-gnome-e7d47e44fc430bb42420db312b96517db4cea8c7.tar.gz
freebsd-ports-gnome-e7d47e44fc430bb42420db312b96517db4cea8c7.tar.zst
freebsd-ports-gnome-e7d47e44fc430bb42420db312b96517db4cea8c7.zip
New port: postgresql-contrib
New port, containing all contrib stuff distributed with postgresql From the README: The PostgreSQL contrib tree --------------------------- This subtree contains porting tools, analysis utilities, and plug-in features that are not part of the core PostgreSQL system, mainly because they address a limited audience or are too experimental to be part of the main source tree. This does not preclude their usefulness. Each subdirectory contains a README file with information about the module. Most items can be built with `gmake all' and installed with `gmake install' in the usual fashion, after you have run the `configure' script in the top-level directory. Some directories supply new user-defined functions, operators, or types. After you have installed the files you need to register the new entities in the database system by running the commands in the supplied .sql file. For example, $ psql -d dbname -f module.sql See the PostgreSQL documentation for more information about this procedure. PR: ports/53181 Submitted by: Palle Girgensohn <girgen@pingpong.net>
Diffstat (limited to 'databases/postgresql-contrib/Makefile')
-rw-r--r--databases/postgresql-contrib/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/databases/postgresql-contrib/Makefile b/databases/postgresql-contrib/Makefile
new file mode 100644
index 000000000000..dd05c9deacb4
--- /dev/null
+++ b/databases/postgresql-contrib/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: postgresql-contrib
+# Date created: June 10, 2003
+# Whom: Palle Girgensohn <girgen@pingpong.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= postgresql-contrib
+PORTREVISION= 0
+CATEGORIES= databases
+
+MAINTAINER= girgen@pingpong.net
+COMMENT= The contrib utilities from the PostgreSQL distribution
+
+LIB_DEPENDS= pq:${PORTSDIR}/${POSTGRESQL_PORT}
+
+POSTGRESQL_PORT?= databases/postgresql7
+POSTGRESQL_SUBPORT=YES
+.include <${.CURDIR}/../../${POSTGRESQL_PORT}/Makefile>
+
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ARGS= --with-libraries=${LOCALBASE}/lib \
+ --with-includes=${LOCALBASE}/include \
+ --docdir=${PREFIX}/share/doc/postgresql
+MAKE_ARGS= -C contrib
+
+pre-build:
+ cd ${WRKSRC}/src/backend ;\
+ ${GMAKE} ../../src/include/parser/parse.h ../../src/include/utils/fmgroids.h
+
+post-install:
+ @ ${INSTALL_DATA} ${WRKSRC}/contrib/README \
+ ${PREFIX}/share/doc/postgresql/contrib/README
+ @ ${ECHO} ==================================== ;\
+ ${SED} -e "s,/usr/local,${PREFIX},g" ${PKGDIR}/pkg-message ;\
+ ${ECHO} ====================================
+
+.include <bsd.port.mk>