aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql-docs/Makefile
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2002-08-27 07:14:23 +0800
committertrevor <trevor@FreeBSD.org>2002-08-27 07:14:23 +0800
commitf69a1c671c89ed126f9a9b639acb9b52bed9697f (patch)
tree8764b72805a4ad95ce9682a771b82c1f1ae9185b /databases/postgresql-docs/Makefile
parenteb5760456414105237c8fd640c665054e0325f4f (diff)
downloadfreebsd-ports-gnome-f69a1c671c89ed126f9a9b639acb9b52bed9697f.tar.gz
freebsd-ports-gnome-f69a1c671c89ed126f9a9b639acb9b52bed9697f.tar.zst
freebsd-ports-gnome-f69a1c671c89ed126f9a9b639acb9b52bed9697f.zip
Add ports/databases/postgresql-docs, which will install the documentation
formerly found in ports/databases/postgresql7. PR: 42008 Submitted by: Palle Girgensohn (maintainer)
Diffstat (limited to 'databases/postgresql-docs/Makefile')
-rw-r--r--databases/postgresql-docs/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/databases/postgresql-docs/Makefile b/databases/postgresql-docs/Makefile
new file mode 100644
index 000000000000..41bfb1091155
--- /dev/null
+++ b/databases/postgresql-docs/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: PostgreSQL docs
+# Date created: August 26, 2002
+# Whom: Palle Girgensohn <girgen@partitur.se>
+#
+# $FreeBSD$
+#
+
+PORTNAME= postgresql
+PKGNAMESUFFIX= -docs
+
+MAINTAINER= girgen@partitur.se
+
+POSTGRESQL_SUBPORT= YES
+.include <${.CURDIR}/../postgresql7/Makefile>
+DISTFILES= postgresql-docs-${PORTVERSION}${EXTRACT_SUFX}
+.undef GNU_CONFIGURE
+NO_BUILD= YES
+
+do-install:
+ $(MKDIR) ${PREFIX}/share/doc/postgresql/html; \
+ ${GZIP_CMD} -dc ${WRKSRC}/doc/postgres.tar.gz | \
+ ( cd $(PREFIX)/share/doc/postgresql/html && $(TAR) xf - )
+
+.include <bsd.port.mk>