aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql-libpqxx
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2012-06-13 06:07:12 +0800
committeravilla <avilla@FreeBSD.org>2012-06-13 06:07:12 +0800
commit24fb4ad4fb7c672799f867d1e1a63bee7f51f352 (patch)
treec1225b5897527f5975ceda29b89d72020ea51e77 /databases/postgresql-libpqxx
parent369b721edfc2062a3faa7ee14e5636da1802b06d (diff)
downloadfreebsd-ports-gnome-24fb4ad4fb7c672799f867d1e1a63bee7f51f352.tar.gz
freebsd-ports-gnome-24fb4ad4fb7c672799f867d1e1a63bee7f51f352.tar.zst
freebsd-ports-gnome-24fb4ad4fb7c672799f867d1e1a63bee7f51f352.zip
- Update libpqxx to 4.0. [1]
- Update CONFLICTS in libpqxx30. - Add instructions to UPDATING for people willing to stick with version 3. Submitted by: arrowdodger via IRC [1]
Diffstat (limited to 'databases/postgresql-libpqxx')
-rw-r--r--databases/postgresql-libpqxx/Makefile16
-rw-r--r--databases/postgresql-libpqxx/distinfo4
-rw-r--r--databases/postgresql-libpqxx/pkg-plist17
3 files changed, 27 insertions, 10 deletions
diff --git a/databases/postgresql-libpqxx/Makefile b/databases/postgresql-libpqxx/Makefile
index 7a3f1e74573a..6b7752551a03 100644
--- a/databases/postgresql-libpqxx/Makefile
+++ b/databases/postgresql-libpqxx/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libpqxx
-PORTVERSION= 3.1
+PORTVERSION= 4.0
CATEGORIES= databases
MASTER_SITES= http://pqxx.org/download/software/libpqxx/
PKGNAMEPREFIX= postgresql-
@@ -22,10 +22,16 @@ USE_PGSQL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-PLIST_SUB= PORTVERSION=${PORTVERSION}
+SOVERSION= 4
+PLIST_SUB= PORTVERSION=${PORTVERSION} \
+ SOVERSION=${SOVERSION}
-CONFIGURE_ARGS= --with-postgres=${LOCALBASE} \
- --enable-shared \
- --with-postgres-include=${LOCALBASE}/include/postgresql
+CONFIGURE_ARGS= --enable-shared \
+ --disable-dependency-tracking
+
+post-install:
+# This is needed for ldconfig
+ ${LN} -s ${PREFIX}/lib/libpqxx-${PORTVERSION}.so \
+ ${PREFIX}/lib/libpqxx.so.${SOVERSION}
.include <bsd.port.mk>
diff --git a/databases/postgresql-libpqxx/distinfo b/databases/postgresql-libpqxx/distinfo
index 2246a393bde7..ea55b7a63fea 100644
--- a/databases/postgresql-libpqxx/distinfo
+++ b/databases/postgresql-libpqxx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (postgresql/libpqxx-3.1.tar.gz) = 8950433f193e118cfd36ab91391eb174ef48897bacc26197da596988e66796a0
-SIZE (postgresql/libpqxx-3.1.tar.gz) = 1771846
+SHA256 (postgresql/libpqxx-4.0.tar.gz) = b160043289cfbf2a186d3b12f9976b6914e76d918d3d4469ff408bd199bbb8ed
+SIZE (postgresql/libpqxx-4.0.tar.gz) = 2631181
diff --git a/databases/postgresql-libpqxx/pkg-plist b/databases/postgresql-libpqxx/pkg-plist
index 13a6e83d4e0b..0528d2f8572e 100644
--- a/databases/postgresql-libpqxx/pkg-plist
+++ b/databases/postgresql-libpqxx/pkg-plist
@@ -17,19 +17,24 @@ include/pqxx/cursor
include/pqxx/cursor.hxx
include/pqxx/dbtransaction
include/pqxx/dbtransaction.hxx
+include/pqxx/errorhandler
+include/pqxx/errorhandler.hxx
include/pqxx/except
include/pqxx/except.hxx
+include/pqxx/field
+include/pqxx/field.hxx
include/pqxx/internal/callgate.hxx
include/pqxx/internal/gates/connection-dbtransaction.hxx
+include/pqxx/internal/gates/connection-errorhandler.hxx
include/pqxx/internal/gates/connection-largeobject.hxx
-include/pqxx/internal/gates/connection-notify-listener.hxx
+include/pqxx/internal/gates/connection-notification_receiver.hxx
include/pqxx/internal/gates/connection-parameterized_invocation.hxx
include/pqxx/internal/gates/connection-pipeline.hxx
-include/pqxx/internal/gates/connection-prepare-declaration.hxx
include/pqxx/internal/gates/connection-prepare-invocation.hxx
include/pqxx/internal/gates/connection-reactivation_avoidance_exemption.hxx
include/pqxx/internal/gates/connection-sql_cursor.hxx
include/pqxx/internal/gates/connection-transaction.hxx
+include/pqxx/internal/gates/errorhandler-connection.hxx
include/pqxx/internal/gates/icursor_iterator-icursorstream.hxx
include/pqxx/internal/gates/icursorstream-icursor_iterator.hxx
include/pqxx/internal/gates/result-connection.hxx
@@ -39,14 +44,17 @@ include/pqxx/internal/gates/transaction-subtransaction.hxx
include/pqxx/internal/gates/transaction-tablereader.hxx
include/pqxx/internal/gates/transaction-tablewriter.hxx
include/pqxx/internal/gates/transaction-transactionfocus.hxx
+include/pqxx/internal/libpq-forward.hxx
+include/pqxx/internal/result_data.hxx
include/pqxx/internal/statement_parameters.hxx
include/pqxx/isolation
include/pqxx/isolation.hxx
include/pqxx/largeobject
include/pqxx/largeobject.hxx
-include/pqxx/libpq-forward.hxx
include/pqxx/nontransaction
include/pqxx/nontransaction.hxx
+include/pqxx/notification
+include/pqxx/notification.hxx
include/pqxx/notify-listen
include/pqxx/notify-listen.hxx
include/pqxx/performance.hxx
@@ -77,6 +85,8 @@ include/pqxx/transactor
include/pqxx/transactor.hxx
include/pqxx/trigger
include/pqxx/trigger.hxx
+include/pqxx/tuple
+include/pqxx/tuple.hxx
include/pqxx/util
include/pqxx/util.hxx
include/pqxx/version
@@ -85,6 +95,7 @@ lib/libpqxx-%%PORTVERSION%%.so
lib/libpqxx.a
lib/libpqxx.la
lib/libpqxx.so
+lib/libpqxx.so.%%SOVERSION%%
libdata/pkgconfig/libpqxx.pc
@dirrm include/pqxx/internal/gates
@dirrm include/pqxx/internal