aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql-pltcl/Makefile
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2002-02-19 16:39:03 +0800
committervanilla <vanilla@FreeBSD.org>2002-02-19 16:39:03 +0800
commit833b433a53b4c5e24cddaffc38357bc3947a850e (patch)
tree9518182646c128aa1072a570741026fdb394d76f /databases/postgresql-pltcl/Makefile
parente71d2fb2e87b181f3d040cca76864b9ba0fd4a7f (diff)
downloadfreebsd-ports-gnome-833b433a53b4c5e24cddaffc38357bc3947a850e.tar.gz
freebsd-ports-gnome-833b433a53b4c5e24cddaffc38357bc3947a850e.tar.zst
freebsd-ports-gnome-833b433a53b4c5e24cddaffc38357bc3947a850e.zip
This is a port of the PL/Tcl module of the postgresql-7.2 distribution.
PR: ports/34859 Submitted by: Palle Girgensohn <girgen@partitur.se>
Diffstat (limited to 'databases/postgresql-pltcl/Makefile')
-rw-r--r--databases/postgresql-pltcl/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/databases/postgresql-pltcl/Makefile b/databases/postgresql-pltcl/Makefile
new file mode 100644
index 000000000000..ce86fac80abb
--- /dev/null
+++ b/databases/postgresql-pltcl/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: PostgreSQL PL/Tcl
+# Date created: January 14, 2002
+# Whom: Palle Girgensohn <girgen@partitur.se>
+#
+# $FreeBSD$
+#
+
+PORTNAME= postgresql-pltcl
+PORTVERSION= 7.2
+CATEGORIES= databases tcl83
+
+MAINTAINER= girgen@partitur.se
+
+POSTGRESQL_SUBPORT=YES
+.include <${.CURDIR}/../postgresql7/Makefile>
+
+LIB_DEPENDS= tcl${TCLVERSION:S/.//}:${PORTSDIR}/lang/tcl${TCLVERSION:S/.//}
+RUN_DEPENDS= postgres:${PORTSDIR}/databases/postgresql7
+
+# you can use "make TCLVERSION=8.4" or similar for your favourite tcl version
+TCLVERSION?= 8.3
+CONFIGURE_ARGS= --with-tcl --without-tk \
+ --with-tclconfig="${TCLCONFIG}" \
+ --with-includes="${TCL_INCDIR}"
+
+TCL_INCDIR= ${LOCALBASE}/include/tcl${TCLVERSION}
+TCLCONFIG= ${LOCALBASE}/lib/tcl${TCLVERSION}
+MAKE_ARGS+= -C src/pl/tcl
+MAKE_ENV+= TCL_INCDIR=${TCL_INCDIR}
+
+post-install:
+ @ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>