aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql-pltcl
diff options
context:
space:
mode:
authorseanc <seanc@FreeBSD.org>2003-12-04 20:00:49 +0800
committerseanc <seanc@FreeBSD.org>2003-12-04 20:00:49 +0800
commita5e6beb57daa17e69c30411c7a53ad8ade67bc7a (patch)
treec88b11bb37189f15d55dc85d36600528d7052697 /databases/postgresql-pltcl
parentcce91232221cb5a5443e53280cfd0738eaa079b4 (diff)
downloadfreebsd-ports-gnome-a5e6beb57daa17e69c30411c7a53ad8ade67bc7a.tar.gz
freebsd-ports-gnome-a5e6beb57daa17e69c30411c7a53ad8ade67bc7a.tar.zst
freebsd-ports-gnome-a5e6beb57daa17e69c30411c7a53ad8ade67bc7a.zip
Introduce the world to PostgreSQL 7.4! By and large this release is
regarded as a major release with features with interest to those with large databases. The updates are extensive and the best source of info is in the release notes. Enjoy and direct questions to database@! Release notes: http://www.postgresql.org/docs/7.4/static/release.html#RELEASE-7-4 PR: ports/59403, ports/59404, ports/59393, ports/59394, ports/59395, ports/59397, ports/59398, ports/59402, && ports/59401 Submitted by: maintainer Approved by: marcus (portmgr@ hat)
Diffstat (limited to 'databases/postgresql-pltcl')
-rw-r--r--databases/postgresql-pltcl/Makefile22
1 files changed, 7 insertions, 15 deletions
diff --git a/databases/postgresql-pltcl/Makefile b/databases/postgresql-pltcl/Makefile
index 8a405a5fdda3..dad6b501987e 100644
--- a/databases/postgresql-pltcl/Makefile
+++ b/databases/postgresql-pltcl/Makefile
@@ -4,31 +4,23 @@
#
# $FreeBSD$
#
-POSTGRESQL_PORT?= databases/postgresql7
-PORTNAME= postgresql
-PORTVERSION!= cd ${.CURDIR}/../../${POSTGRESQL_PORT} && ${MAKE} -V PORTVERSION
-PORTREVISION?= 0
-CATEGORIES= databases tcl83
-MASTER_SITES= ${MASTER_SITE_PGSQL}
-MASTER_SITE_SUBDIR!= cd ${.CURDIR}/../../${POSTGRESQL_PORT} && ${MAKE} -V MASTER_SITE_SUBDIR
+PORTREVISION= 0
+CATEGORIES= databases tcl${TCLVERSION:S/.//}
PKGNAMESUFFIX= -pltcl
-DISTFILES!= cd ${.CURDIR}/../../${POSTGRESQL_PORT} && ${MAKE} -V DISTFILES
-DIST_SUBDIR= postgresql
MAINTAINER= girgen@pingpong.net
COMMENT= A module for using Tcl to write SQL functions
+POSTGRESQL_PORT?= databases/postgresql7
+POSTGRESQL_SUBPORT=YES
+.include "../../${POSTGRESQL_PORT}/Makefile"
+
LIB_DEPENDS= tcl${TCLVERSION:S/.//}:${PORTSDIR}/lang/tcl${TCLVERSION:S/.//}
RUN_DEPENDS= postgres:${PORTSDIR}/${POSTGRESQL_PORT}
-MD5_FILE= ${.CURDIR}/../../${POSTGRESQL_PORT}/distinfo
-
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-
# you can use "make TCLVERSION=8.4" or similar for your favourite tcl version
-TCLVERSION?= 8.3
+TCLVERSION?= 8.4
CONFIGURE_ARGS= --with-tcl --without-tk \
--with-tclconfig="${TCLCONFIG}" \
--with-includes="${TCL_INCDIR}"