aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql-tcltk/Makefile
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2003-09-04 20:27:19 +0800
committerosa <osa@FreeBSD.org>2003-09-04 20:27:19 +0800
commit6c6c69d4ddebd88f4dfe7b18845edc6b25936215 (patch)
tree58524bc35aa8e0350263fc8e9d31b8966f0cfb91 /databases/postgresql-tcltk/Makefile
parent807d300a37b951360a14a90528d34648356d66bd (diff)
downloadfreebsd-ports-gnome-6c6c69d4ddebd88f4dfe7b18845edc6b25936215.tar.gz
freebsd-ports-gnome-6c6c69d4ddebd88f4dfe7b18845edc6b25936215.tar.zst
freebsd-ports-gnome-6c6c69d4ddebd88f4dfe7b18845edc6b25936215.zip
Use new depends scheme for postgresql slave ports:
${MAKE} -V ... instead of .include <...> Submitted by: Palle Girgensohn <girgen@pingpong.net> (maintainer) PR: 56349, 56404
Diffstat (limited to 'databases/postgresql-tcltk/Makefile')
-rw-r--r--databases/postgresql-tcltk/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/databases/postgresql-tcltk/Makefile b/databases/postgresql-tcltk/Makefile
index 95f332b6ebf9..236885ed8c57 100644
--- a/databases/postgresql-tcltk/Makefile
+++ b/databases/postgresql-tcltk/Makefile
@@ -4,21 +4,26 @@
#
# $FreeBSD$
#
+POSTGRESQL_PORT?= databases/postgresql7
-PORTNAME= postgresql-tcltk
+PORTNAME= postgresql
+PORTVERSION!= ${MAKE} -C ${.CURDIR}/../../${POSTGRESQL_PORT} -V PORTVERSION
+PORTREVISION?= 0
CATEGORIES= databases tcl83 tk83
-PORTREVISION= 0
+MASTER_SITES= ${MASTER_SITE_PGSQL}
+MASTER_SITE_SUBDIR!= ${MAKE} -C ${.CURDIR}/../../${POSTGRESQL_PORT} -V MASTER_SITE_SUBDIR
+PKGNAMESUFFIX= -tcltk
+DISTFILES!= ${MAKE} -C ${.CURDIR}/../../${POSTGRESQL_PORT} -V DISTFILES
+DIST_SUBDIR= postgresql
MAINTAINER= girgen@pingpong.net
COMMENT= An TCL interface to the database PostgreSQL, including a tk GUI
-POSTGRESQL_PORT?= databases/postgresql7
-POSTGRESQL_SUBPORT=YES
-.include <${.CURDIR}/../../${POSTGRESQL_PORT}/Makefile>
-
LIB_DEPENDS= tcl${TCLVERSION:S/.//}:${PORTSDIR}/lang/tcl${TCLVERSION:S/.//} \
pq:${PORTSDIR}/${POSTGRESQL_PORT}
+MD5_FILE= ${.CURDIR}/../../${POSTGRESQL_PORT}/distinfo
+
# you can use "make TCLVERSION=8.4" or similar for your favourite tcl version
TCLVERSION?= 8.3
PLIST_SUB+= TCLVERSION=${TCLVERSION}