aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql-tcltk/Makefile
diff options
context:
space:
mode:
authorgirgen <girgen@FreeBSD.org>2005-01-31 08:20:43 +0800
committergirgen <girgen@FreeBSD.org>2005-01-31 08:20:43 +0800
commitcbe074a01a678ad3149123153f48962b4b035576 (patch)
tree448881df420ea4be6fb92801d4304ed4bb19e828 /databases/postgresql-tcltk/Makefile
parent1b4d43c02fc95c9d49267c9f361f94537168552a (diff)
downloadfreebsd-ports-gnome-cbe074a01a678ad3149123153f48962b4b035576.tar.gz
freebsd-ports-gnome-cbe074a01a678ad3149123153f48962b4b035576.tar.zst
freebsd-ports-gnome-cbe074a01a678ad3149123153f48962b4b035576.zip
Split the postgresql ports into a server and a client part.
The tcltk interface has been removed from the main distribution, so fixate the version number to the latest released version, 7.4.6. PR: 75344 Approved by: portmgr@ (kris), ade & sean (mentors)
Diffstat (limited to 'databases/postgresql-tcltk/Makefile')
-rw-r--r--databases/postgresql-tcltk/Makefile40
1 files changed, 19 insertions, 21 deletions
diff --git a/databases/postgresql-tcltk/Makefile b/databases/postgresql-tcltk/Makefile
index b9aeea64df0a..af214548d7e2 100644
--- a/databases/postgresql-tcltk/Makefile
+++ b/databases/postgresql-tcltk/Makefile
@@ -1,23 +1,26 @@
-# New ports collection makefile for: PostgreSQL JDBC
+# New ports collection makefile for: PostgreSQL Tcl/Tk
# Date created: January 14, 2002
# Whom: Palle Girgensohn <girgen@partitur.se>
#
# $FreeBSD$
#
-PORTREVISION= 1
-CATEGORIES= databases tcl${TCLVERSION:S/.//}
+PORTNAME= postgresql
+PORTREVISION= 0
+CATEGORIES?= databases tcl${TCLVERSION:C/[^0-9]//g}
PKGNAMESUFFIX= -tcltk
MAINTAINER= girgen@FreeBSD.org
-COMMENT= An TCL interface to the database PostgreSQL, including a tk GUI
+COMMENT= A TCL interface to the database PostgreSQL, including a tk GUI
-POSTGRESQL_PORT?= databases/postgresql7
-POSTGRESQL_SUBPORT=YES
-.include <${.CURDIR}/../../${POSTGRESQL_PORT}/Makefile>
+TCLPORTDIR?= ${PORTSDIR}/lang/tcl
+TKPORTDIR?= ${PORTSDIR}/x11-toolkits/tk
+LIB_DEPENDS= tcl${TCLVERSION:S/.//}:${TCLPORTDIR}${TCLVERSION:C/[^0-9]//g}
-LIB_DEPENDS= tcl${TCLVERSION:S/.//}:${PORTSDIR}/lang/tcl${TCLVERSION:S/.//} \
- pq:${PORTSDIR}/${POSTGRESQL_PORT}
+USE_PGSQL= yes
+MASTERDIR= ${.CURDIR}/../../databases/postgresql74-server
+
+CONFLICTS= ${PORTNAME}${PKGNAMESUFFIX}-7.[0-3]*
# you can use "make TCLVERSION=8.4" or similar for your favourite tcl version
TCLVERSION?= 8.4
@@ -47,26 +50,21 @@ PLIST_SUB+= TK="@comment "
CONFIGURE_ARGS+= --with-tkconfig="${TKCONFIG}"
TK_INCDIR= ${LOCALBASE}/include/tk${TCLVERSION}
CONFIGURE_ENV+= WISH=${LOCALBASE}/bin/wish${TCLVERSION}
-LIB_DEPENDS+= tk${TCLVERSION:S/.//}:${PORTSDIR}/x11-toolkits/tk${TCLVERSION:S/.//}
+LIB_DEPENDS+= tk${TCLVERSION:S/.//}:${TKPORTDIR}${TCLVERSION:C/[^0-9]//g}
TKCONFIG= ${LOCALBASE}/lib/tk${TCLVERSION}
INCDIRS= ${TCL_INCDIR}:${TK_INCDIR}
PLIST_SUB+= TK=""
-CATEGORIES+= tk${TCLVERSION:S/.//}
+CATEGORIES+= tk${TCLVERSION:C/[^0-9]//g}
.endif
-pre-build:
- cd ${WRKSRC}/src/port; ${GMAKE}
-
-do-build:
- @ cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${GMAKE} -C src/bin/pgtclsh
- @ cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${GMAKE} -C src/interfaces/libpgtcl
+BUILD_DIRS= src/port ${INSTALL_DIRS}
+INSTALL_DIRS= src/bin/pgtclsh src/interfaces/libpgtcl
+SLAVE_ONLY= yes
-do-install:
- @ cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${GMAKE} -C src/bin/pgtclsh install
- @ cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${GMAKE} -C src/interfaces/libpgtcl install
+post-install:
# Preparing a loadable TCL-package (pkgIndex.tcl)
@${MKDIR} ${PREFIX}/lib/tcl${TCLVERSION}/Pgtcl1.3
@${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/pkgIndex.tcl.in \
> ${PREFIX}/lib/tcl${TCLVERSION}/Pgtcl1.3/pkgIndex.tcl
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"