aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql73-server/Makefile
diff options
context:
space:
mode:
authorclive <clive@FreeBSD.org>2001-03-16 03:26:26 +0800
committerclive <clive@FreeBSD.org>2001-03-16 03:26:26 +0800
commitc08f96610519200bf9cf80cee9309c4df9c63d9a (patch)
tree6b2daa11db5b8e469cf159e0b76baf4e7181e516 /databases/postgresql73-server/Makefile
parentea3e67526f352bd9c45d1cac952a53cb3da86900 (diff)
downloadfreebsd-ports-gnome-c08f96610519200bf9cf80cee9309c4df9c63d9a.tar.gz
freebsd-ports-gnome-c08f96610519200bf9cf80cee9309c4df9c63d9a.tar.zst
freebsd-ports-gnome-c08f96610519200bf9cf80cee9309c4df9c63d9a.zip
ldconfig PostgreSQL's lib should happen before starting *ANY* ports.
This would cure headache like apache module linking against libpq fail to work after rebooting. Originally, maintainer and I want this commit to go with the PostgreSQL updating. But we both think that the latest PostgreSQL would not be released before FreeBSD 4.3-RELEASE ports freeze. As a conclusion, PORTREVISION bumped. Discussed with/Submitted by: MAINTAINER
Diffstat (limited to 'databases/postgresql73-server/Makefile')
-rw-r--r--databases/postgresql73-server/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/databases/postgresql73-server/Makefile b/databases/postgresql73-server/Makefile
index 313ef570c06d..e5d237658c2a 100644
--- a/databases/postgresql73-server/Makefile
+++ b/databases/postgresql73-server/Makefile
@@ -7,6 +7,7 @@
PORTNAME= postgresql
PORTVERSION= 7.0.3
+PORTREVISION= 1
CATEGORIES= databases
MASTER_SITES= ftp://ftp.postgresql.org/pub/%SUBDIR%/ \
ftp://ftp.de.postgresql.org/%SUBDIR%/ \
@@ -133,9 +134,9 @@ post-install:
@ ${CHOWN} root:pgsql ${PREFIX}/pgsql/lib
@ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/pgsql/lib
@ ${SED} -e "s=!!PREFIX!!=${PREFIX}=g" < ${FILESDIR}/pgsql.sh.tmpl \
- > ${PREFIX}/etc/rc.d/pgsql.sh
- @ ${CHMOD} 554 ${PREFIX}/etc/rc.d/pgsql.sh
- @ ${CHOWN} root.pgsql ${PREFIX}/etc/rc.d/pgsql.sh
+ > ${PREFIX}/etc/rc.d/010.pgsql.sh
+ @ ${CHMOD} 554 ${PREFIX}/etc/rc.d/010.pgsql.sh
+ @ ${CHOWN} root.pgsql ${PREFIX}/etc/rc.d/010.pgsql.sh
@ ${SED} -e 's#%%PREFIX%%#${PREFIX}#' < ${FILESDIR}/post-install-notes \
> ${PREFIX}/pgsql/post-install-notes
.if defined(WITHOUT_MULTIBYTE)