aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql80-server
diff options
context:
space:
mode:
authorscrappy <scrappy@FreeBSD.org>1997-04-11 03:15:12 +0800
committerscrappy <scrappy@FreeBSD.org>1997-04-11 03:15:12 +0800
commit740691dc26e4b8ff41d912092da25a7bafb5454c (patch)
tree79b5ecc505e1c1428fe271c5c297633d536c30df /databases/postgresql80-server
parentda0fd2d1718536faafb04297c6e121790f74e336 (diff)
downloadfreebsd-ports-gnome-740691dc26e4b8ff41d912092da25a7bafb5454c.tar.gz
freebsd-ports-gnome-740691dc26e4b8ff41d912092da25a7bafb5454c.tar.zst
freebsd-ports-gnome-740691dc26e4b8ff41d912092da25a7bafb5454c.zip
Update postgresql port from v1.09 to v6.0 using files from PostgreSQL
port, which is going to be removed
Diffstat (limited to 'databases/postgresql80-server')
-rw-r--r--databases/postgresql80-server/Makefile99
-rw-r--r--databases/postgresql80-server/distinfo1
-rw-r--r--databases/postgresql80-server/files/post-install-notes8
-rw-r--r--databases/postgresql80-server/pkg-descr20
-rw-r--r--databases/postgresql80-server/pkg-plist316
-rw-r--r--databases/postgresql80-server/scripts/createuser16
6 files changed, 231 insertions, 229 deletions
diff --git a/databases/postgresql80-server/Makefile b/databases/postgresql80-server/Makefile
index 8fe4bc783e44..d75977ce0a5c 100644
--- a/databases/postgresql80-server/Makefile
+++ b/databases/postgresql80-server/Makefile
@@ -1,66 +1,61 @@
-# New ports collection makefile for: postgres95
-# Version required: 1.08
-# Date created: Oct 9 1996
-# Whom: Matthew Stein <matt@bdd.net>
+# New ports collection makefile for: PostgreSQL
+# Version required: 6.0
+# Date created: April 2, 1997
+# Whom: Marc G. Fournier <scrappy@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.7 1997/04/02 09:15:26 scrappy Exp $
+# $Id: Makefile,v 1.2 1997/04/02 18:17:50 jfitz Exp $
-PKGNAME= postgres95-1.08
+DISTNAME= postgresql-v6.0
+PKGNAME= postgresql-6.0
CATEGORIES= databases
-MASTER_SITES= ftp://ftp.PostgreSQL.org/pub/oldstuff/ \
- ftp://ftp.jaist.ac.jp/pub/dbms/postgres95/oldstuff/ \
- ftp://postgres95.vnet.net:/pub/postgres95/oldstuff/ \
- ftp://ftp.itm.tu-clausthal.de/pub/mirrors/postgres95/oldstuff/ \
- ftp://rocker.sch.bme.hu/pub/mirrors/postgreSQL/oldstuff/ \
- ftp://ftp.luga.or.at/pub/postgres95/
-
-DISTFILES= postgres95-1.08.tar.gz \
- flex-2.5.2.tgz
+MASTER_SITES= ftp://ftp.PostgreSQL.org/pub/ \
+ ftp://ftp.luga.or.at/pub/postgres95/ \
+ ftp://ftp.jaist.ac.jp/pub/dbms/postgres95/
-MAINTAINER= matt@bdd.net
-
-NO_PACKAGE= "Requires postgres uid"
-WRKSRC= ${WRKDIR}/postgres95/src/
-MAKE_ENV+= WRKSRC=${WRKSRC} WRKDIR=${WRKDIR}
-USE_GMAKE= yes
-
-pre-fetch:
-.if exists(/usr/lib/libc.so.3.0)
- @ ${CAT} ${FILESDIR}/md5.libc30 ${FILESDIR}/md5.all > ${FILESDIR}/md5
-MASTER_SITES+= ftp://eddie.cis.uoguelph.ca/pub/flex/ \
- ftp://ftp.teamos2.org/pub/flex/ \
- ftp://ftp.bdd.net/pub/flex/
-.else
- @ ${CAT} ${FILESDIR}/md5.libc22 ${FILESDIR}/md5.all > ${FILESDIR}/md5
-MASTER_SITES+= ftp://ftp.freebsd.org/pub/FreeBSD/packages-2.1.5/All/
-.endif
+MAINTAINER= scrappy@FreeBSD.ORG
+
+NO_PACKAGE= "Requires pgsql uid"
+WRKSRC= ${WRKDIR}/src
+USE_GMAKE= YES
+MAKEFILE= GNUmakefile
+
+MAN1= createdb.1 psql.1 unix.1 postgres.1 pg_dumpall.1 monitor.1 \
+ initdb.1 ipcclean.1 destroydb.1 cleardbdir.1 createuser.1 \
+ destroyuser.1 pg_dump.1 postmaster.1
+MAN3= libpq.3 large_objects.3 built-in.3 catalogs.3
+MAN5= pg_hba.conf.5 bki.5 page.5
+MANL= vacuum.l sql.l select.l update.l revoke.l rename.l purge.l \
+ load.l listen.l insert.l fetch.l end.l grant.l drop_rule.l \
+ drop_type.l drop_function.l create_aggregate.l drop.l \
+ delete.l destroydb.l create_view.l create_rule.l \
+ create_index.l copy.l cluster.l create_database.l \
+ create_function.l begin.l abort.l alter_table.l close.l \
+ create_operator.l create_table.l create_type.l \
+ create_version.l drop_aggregate.l drop_operator.l explain.l \
+ notify.l remove_view.l rollback.l commit.l drop_index.l
+MANPREFIX= ${PREFIX}/pgsql
pre-install:
- @ ${MKDIR} ${PREFIX}/postgres95
+ @ ${MKDIR} ${PREFIX}/pgsql
@ ${SETENV} ${MAKE_ENV} /usr/bin/perl ${SCRIPTDIR}/createuser
post-install:
-.if !defined(NOMANCOMPRESS)
- @ for file in ${PREFIX}/postgres95/man/man[135l]/*; do \
- gzip -9nf $$file ; \
- done
-.endif
- @ chown -R postgres:postgres ${PREFIX}/postgres95
- @ echo 'Initializing Postgres95 Databases - this may take a few minutes...'
- @ su -l postgres -c ${PREFIX}/postgres95/bin/initdb
- @ ${MKDIR} ${PREFIX}/etc/rc.d
- @ if [ ! -f ${PREFIX}/etc/rc.d/postgres95.sh ]; then \
- echo "Installing ${PREFIX}/etc/rc.d/postgres95.sh startup file."; \
- echo "#!/bin/sh" > ${PREFIX}/etc/rc.d/postgres95.sh; \
- echo "[ -x ${PREFIX}/postgres95/bin/postmaster ] && su -l postgres -c ${PREFIX}/postgres95/bin/postmaster & && echo -n ' postgres95'" >> ${PREFIX}/etc/rc.d/postgres95.sh; \
- chmod 751 ${PREFIX}/etc/rc.d/postgres95.sh; \
+ @ chown -R pgsql:pgsql ${PREFIX}/pgsql
+ @ if [ ! -f ${PREFIX}/pgsql/.profile ]; then \
+ echo "PATH=\${PATH}:${PREFIX}/pgsql/bin" > ${PREFIX}/pgsql/.profile; \
+ echo "export PATH" >> ${PREFIX}/pgsql/.profile; \
+ fi
+ @ echo 'Initializing PostgreSQL Databases - this may take a few minutes...'
+ @ su -l pgsql -c '${PREFIX}/pgsql/bin/initdb --pglib=${PREFIX}/pgsql/lib --pgdata=${PREFIX}/pgsql/data'
+ @ if [ ! -f ${PREFIX}/etc/rc.d/postgresql.sh ]; then \
+ echo "Installing ${PREFIX}/etc/rc.d/postgresql.sh startup file."; \
+ echo "#!/bin/sh" > ${PREFIX}/etc/rc.d/postgresql.sh; \
+ echo "[ -x ${PREFIX}/pgsql/bin/postmaster ] && su -l pgsql -c '${PREFIX}/pgsql/bin/postmaster -D${PREFIX}/pgsql/data -o -F > ${PREFIX}/pgsql/errlog &' && echo -n ' pgsql'" >> ${PREFIX}/etc/rc.d/postgresql.sh; \
+ chmod 751 ${PREFIX}/etc/rc.d/postgresql.sh; \
fi
- @ ${INSTALL_DATA} ${FILESDIR}/post-install-notes ${PREFIX}/postgres95
-.ifndef(BATCH)
+ @ ${INSTALL_DATA} ${FILESDIR}/post-install-notes ${PREFIX}/pgsql
+.if !defined(BATCH)
@ more -e ${FILESDIR}/post-install-notes
.endif
-pre-clean:
- @ ${RM} -f ${FILESDIR}/md5
-
.include <bsd.port.mk>
diff --git a/databases/postgresql80-server/distinfo b/databases/postgresql80-server/distinfo
new file mode 100644
index 000000000000..6e38772d6134
--- /dev/null
+++ b/databases/postgresql80-server/distinfo
@@ -0,0 +1 @@
+MD5 (postgresql-v6.0.tar.gz) = f58a0cd9beec65a473b76a19409bdedd
diff --git a/databases/postgresql80-server/files/post-install-notes b/databases/postgresql80-server/files/post-install-notes
index 6d26c8799339..1956d17766c9 100644
--- a/databases/postgresql80-server/files/post-install-notes
+++ b/databases/postgresql80-server/files/post-install-notes
@@ -1,8 +1,6 @@
-Now that postgres95 is installed, you should read the documentation and
-implementation guides. These can be found at
+Now that PostgreSQL is installed, you should read the documentation and
+implementation guides. These can be found at:
-http://www.PostgreSQL.org/docs/
+ http://www.PostgreSQL.org/docs
---
-mat.
diff --git a/databases/postgresql80-server/pkg-descr b/databases/postgresql80-server/pkg-descr
index 2743afb25835..9cefa466a8c0 100644
--- a/databases/postgresql80-server/pkg-descr
+++ b/databases/postgresql80-server/pkg-descr
@@ -1,20 +1,20 @@
-Postgres95 is an enhancement of the POSTGRES database management system, a
-next-generation DBMS research prototype. While Postgres95 retains the
+PostgreSQL is an enhancement of the POSTGRES database management system, a
+next-generation DBMS research prototype. While PostgreSQL retains the
powerful data model and rich data types of POSTGRES, it replaces the
-PostQuel query language with an extended subset of SQL. Postgres95 is free
+PostQuel query language with an extended subset of SQL. PostgreSQL is free
and the complete source is available.
-Postgres95 development is being performed by a team of Internet developers
-who all subscribe to the Postgres95 development mailing list. The current
-coordinator is Marc G. Fournier (scrappy@ki.net). This team is now
-responsible for all current and future development of Postgres95.
+PostgreSQL development is being performed by a team of Internet developers
+who all subscribe to the PostgreSQL development mailing list. The current
+coordinator is Marc G. Fournier (scrappy@postgresql.org). This team is now
+responsible for all current and future development of PostgreSQL.
The authors of Postgres95 1.01 were Andrew Yu and Jolly Chen. Many others
have contributed to the porting, testing, debugging and enhancement of the
-code. The original Postgres code, from which Postgres95 is derived, was the
+code. The original Postgres code, from which PostgreSQL is derived, was the
effort of many graduate students, undergraduate students, and staff
programmers working under the direction of Professor Michael Stonebraker at
the University of California, Berkeley.
-More information and documentation can be found at the postgres95 website,
-at http://www.ki.net/postgres95/
+More information and documentation can be found at the PostgreSQL website,
+at http://www.PostgreSQL.org
diff --git a/databases/postgresql80-server/pkg-plist b/databases/postgresql80-server/pkg-plist
index 43a0ebb2e780..e3c2513f015f 100644
--- a/databases/postgresql80-server/pkg-plist
+++ b/databases/postgresql80-server/pkg-plist
@@ -1,154 +1,162 @@
-etc/rc.d/postgres95.sh
-postgres95/lib/libpq.a
-postgres95/bin/postgres
-postgres95/bin/postmaster
-postgres95/bin/pg_id
-postgres95/bin/pg_version
-postgres95/bin/psql
-postgres95/bin/pg_dump
-postgres95/bin/cleardbdir
-postgres95/bin/createdb
-postgres95/bin/createuser
-postgres95/bin/destroydb
-postgres95/bin/destroyuser
-postgres95/bin/initdb
-postgres95/data/files/global1.bki
-postgres95/data/files/global1.bki.source
-postgres95/data/files/local1_template1.bki
-postgres95/data/files/local1_template1.bki.source
-postgres95/data/pg_hba
-postgres95/data/base/template1/pg_proc
-postgres95/data/base/template1/pg_type
-postgres95/data/base/template1/pg_attribute
-postgres95/data/base/template1/pg_class
-postgres95/data/base/template1/pg_inherits
-postgres95/data/base/template1/pg_index
-postgres95/data/base/template1/pg_version
-postgres95/data/base/template1/pg_statistic
-postgres95/data/base/template1/pg_operator
-postgres95/data/base/template1/pg_opclass
-postgres95/data/base/template1/pg_am
-postgres95/data/base/template1/pg_amop
-postgres95/data/base/template1/pg_amproc
-postgres95/data/base/template1/pg_language
-postgres95/data/base/template1/pg_parg
-postgres95/data/base/template1/pg_aggregate
-postgres95/data/base/template1/pg_ipl
-postgres95/data/base/template1/pg_inheritproc
-postgres95/data/base/template1/pg_rewrite
-postgres95/data/base/template1/pg_listener
-postgres95/data/base/template1/pg_attnameind
-postgres95/data/base/template1/pg_attnumind
-postgres95/data/base/template1/pg_attrelidind
-postgres95/data/base/template1/pg_procidind
-postgres95/data/base/template1/pg_procnameind
-postgres95/data/base/template1/pg_procsrcind
-postgres95/data/base/template1/pg_typeidind
-postgres95/data/base/template1/pg_typenameind
-postgres95/data/base/template1/pg_classnameind
-postgres95/data/base/template1/pg_classoidind
-postgres95/data/base/template1/PG_VERSION
-postgres95/data/base/template1/pg_internal.init
-postgres95/data/pg_variable
-postgres95/data/pg_database
-postgres95/data/pg_demon
-postgres95/data/pg_magic
-postgres95/data/pg_defaults
-postgres95/data/pg_server
-postgres95/data/pg_user
-postgres95/data/pg_hosts
-postgres95/data/pg_group
-postgres95/data/pg_log
-postgres95/data/pg_time
-postgres95/data/PG_VERSION
-postgres95/include/fmgr.h
-postgres95/include/lib/dllist.h
-postgres95/include/libpq/pqcomm.h
-postgres95/include/libpq/libpq-fs.h
-postgres95/include/utils/geo-decls.h
-postgres95/include/libpq-fe.h
-postgres95/include/postgres.h
-postgres95/include/c.h
-postgres95/man/man1/cleardbdir.1.gz
-postgres95/man/man1/psql.1.gz
-postgres95/man/man1/postmaster.1.gz
-postgres95/man/man1/postgres.1.gz
-postgres95/man/man1/pg_dump.1.gz
-postgres95/man/man1/monitor.1.gz
-postgres95/man/man1/ipcclean.1.gz
-postgres95/man/man1/initdb.1.gz
-postgres95/man/man1/destroyuser.1.gz
-postgres95/man/man1/destroydb.1.gz
-postgres95/man/man1/createuser.1.gz
-postgres95/man/man1/createdb.1.gz
-postgres95/man/man1/unix.1.gz
-postgres95/man/man3/libpq.3.gz
-postgres95/man/man3/large_objects.3.gz
-postgres95/man/man3/catalogs.3.gz
-postgres95/man/man3/built-in.3.gz
-postgres95/man/man5/template.5.gz
-postgres95/man/man5/pg_hba.5.gz
-postgres95/man/man5/page.5.gz
-postgres95/man/man5/files.5.gz
-postgres95/man/man5/bki.5.gz
-postgres95/man/manl/abort.l.gz
-postgres95/man/manl/update.l.gz
-postgres95/man/manl/sql.l.gz
-postgres95/man/manl/select.l.gz
-postgres95/man/manl/rollback.l.gz
-postgres95/man/manl/revoke.l.gz
-postgres95/man/manl/rename.l.gz
-postgres95/man/manl/remove_view.l.gz
-postgres95/man/manl/purge.l.gz
-postgres95/man/manl/notify.l.gz
-postgres95/man/manl/load.l.gz
-postgres95/man/manl/listen.l.gz
-postgres95/man/manl/insert.l.gz
-postgres95/man/manl/grant.l.gz
-postgres95/man/manl/fetch.l.gz
-postgres95/man/manl/end.l.gz
-postgres95/man/manl/drop_type.l.gz
-postgres95/man/manl/drop_rule.l.gz
-postgres95/man/manl/drop_operator.l.gz
-postgres95/man/manl/drop_index.l.gz
-postgres95/man/manl/drop_function.l.gz
-postgres95/man/manl/drop_aggregate.l.gz
-postgres95/man/manl/drop.l.gz
-postgres95/man/manl/destroydb.l.gz
-postgres95/man/manl/copy.l.gz
-postgres95/man/manl/delete.l.gz
-postgres95/man/manl/create_database.l.gz
-postgres95/man/manl/create_view.l.gz
-postgres95/man/manl/create_version.l.gz
-postgres95/man/manl/create_type.l.gz
-postgres95/man/manl/create_table.l.gz
-postgres95/man/manl/create_rule.l.gz
-postgres95/man/manl/create_operator.l.gz
-postgres95/man/manl/create_index.l.gz
-postgres95/man/manl/create_function.l.gz
-postgres95/man/manl/create_aggregate.l.gz
-postgres95/man/manl/commit.l.gz
-postgres95/man/manl/cluster.l.gz
-postgres95/man/manl/close.l.gz
-postgres95/man/manl/begin.l.gz
-postgres95/man/manl/alter_table.l.gz
-postgres95/man/manl/vacuum.l.gz
-postgres95/post-install-notes
-@dirrm postgres95/man/man1/
-@dirrm postgres95/man/man3/
-@dirrm postgres95/man/man5/
-@dirrm postgres95/man/manl/
-@dirrm postgres95/man/
-@dirrm postgres95/lib/
-@dirrm postgres95/include/utils/
-@dirrm postgres95/include/port/BSD44_derived/
-@dirrm postgres95/include/port/
-@dirrm postgres95/include/libpq/
-@dirrm postgres95/include/lib/
-@dirrm postgres95/include/
-@dirrm postgres95/data/files/
-@dirrm postgres95/data/base/template1/
-@dirrm postgres95/data/base/
-@dirrm postgres95/data/
-@dirrm postgres95/bin/
-@dirrm postgres95/
+etc/rc.d/postgresql.sh
+pgsql/lib/global1.bki.source
+pgsql/lib/local1_template1.bki.source
+pgsql/lib/pg_hba.conf.sample
+pgsql/lib/libpq.a
+pgsql/bin/postgres
+pgsql/bin/postmaster
+pgsql/bin/pg_id
+pgsql/bin/pg_version
+pgsql/bin/psql
+pgsql/bin/pg_dump
+pgsql/bin/pg_dumpall
+pgsql/bin/cleardbdir
+pgsql/bin/createdb
+pgsql/bin/createuser
+pgsql/bin/destroydb
+pgsql/bin/destroyuser
+pgsql/bin/initdb
+pgsql/include/fmgr.h
+pgsql/include/lib/dllist.h
+pgsql/include/libpq/pqcomm.h
+pgsql/include/libpq/libpq-fs.h
+pgsql/include/utils/geo-decls.h
+pgsql/include/utils/elog.h
+pgsql/include/utils/palloc.h
+pgsql/include/access/attnum.h
+pgsql/include/config.h
+pgsql/include/postgres.h
+pgsql/include/postgres_ext.h
+pgsql/include/libpq-fe.h
+pgsql/include/c.h
+pgsql/man/man1/createdb.1.gz
+pgsql/man/man1/psql.1.gz
+pgsql/man/man1/unix.1.gz
+pgsql/man/man1/postgres.1.gz
+pgsql/man/man1/pg_dumpall.1.gz
+pgsql/man/man1/monitor.1.gz
+pgsql/man/man1/initdb.1.gz
+pgsql/man/man1/ipcclean.1.gz
+pgsql/man/man1/destroydb.1.gz
+pgsql/man/man1/cleardbdir.1.gz
+pgsql/man/man1/createuser.1.gz
+pgsql/man/man1/destroyuser.1.gz
+pgsql/man/man1/pg_dump.1.gz
+pgsql/man/man1/postmaster.1.gz
+pgsql/man/man3/libpq.3.gz
+pgsql/man/man3/large_objects.3.gz
+pgsql/man/man3/built-in.3.gz
+pgsql/man/man3/catalogs.3.gz
+pgsql/man/man5/pg_hba.conf.5.gz
+pgsql/man/man5/bki.5.gz
+pgsql/man/man5/page.5.gz
+pgsql/man/manl/vacuum.l.gz
+pgsql/man/manl/sql.l.gz
+pgsql/man/manl/select.l.gz
+pgsql/man/manl/update.l.gz
+pgsql/man/manl/revoke.l.gz
+pgsql/man/manl/rename.l.gz
+pgsql/man/manl/purge.l.gz
+pgsql/man/manl/load.l.gz
+pgsql/man/manl/listen.l.gz
+pgsql/man/manl/insert.l.gz
+pgsql/man/manl/fetch.l.gz
+pgsql/man/manl/end.l.gz
+pgsql/man/manl/grant.l.gz
+pgsql/man/manl/drop_rule.l.gz
+pgsql/man/manl/drop_type.l.gz
+pgsql/man/manl/drop_index.l.gz
+pgsql/man/manl/drop_function.l.gz
+pgsql/man/manl/create_aggregate.l.gz
+pgsql/man/manl/drop.l.gz
+pgsql/man/manl/delete.l.gz
+pgsql/man/manl/destroydb.l.gz
+pgsql/man/manl/create_view.l.gz
+pgsql/man/manl/create_rule.l.gz
+pgsql/man/manl/create_index.l.gz
+pgsql/man/manl/copy.l.gz
+pgsql/man/manl/commit.l.gz
+pgsql/man/manl/cluster.l.gz
+pgsql/man/manl/create_database.l.gz
+pgsql/man/manl/create_function.l.gz
+pgsql/man/manl/begin.l.gz
+pgsql/man/manl/abort.l.gz
+pgsql/man/manl/alter_table.l.gz
+pgsql/man/manl/close.l.gz
+pgsql/man/manl/create_operator.l.gz
+pgsql/man/manl/create_table.l.gz
+pgsql/man/manl/create_type.l.gz
+pgsql/man/manl/create_version.l.gz
+pgsql/man/manl/drop_aggregate.l.gz
+pgsql/man/manl/drop_operator.l.gz
+pgsql/man/manl/explain.l.gz
+pgsql/man/manl/notify.l.gz
+pgsql/man/manl/remove_view.l.gz
+pgsql/man/manl/rollback.l.gz
+pgsql/.profile
+pgsql/data/base/template1/pg_proc
+pgsql/data/base/template1/pg_type
+pgsql/data/base/template1/pg_attribute
+pgsql/data/base/template1/pg_class
+pgsql/data/base/template1/pg_inherits
+pgsql/data/base/template1/pg_index
+pgsql/data/base/template1/pg_version
+pgsql/data/base/template1/pg_statistic
+pgsql/data/base/template1/pg_operator
+pgsql/data/base/template1/pg_opclass
+pgsql/data/base/template1/pg_am
+pgsql/data/base/template1/pg_amop
+pgsql/data/base/template1/pg_amproc
+pgsql/data/base/template1/pg_language
+pgsql/data/base/template1/pg_parg
+pgsql/data/base/template1/pg_aggregate
+pgsql/data/base/template1/pg_ipl
+pgsql/data/base/template1/pg_inheritproc
+pgsql/data/base/template1/pg_rewrite
+pgsql/data/base/template1/pg_listener
+pgsql/data/base/template1/pg_attnameind
+pgsql/data/base/template1/pg_attnumind
+pgsql/data/base/template1/pg_attrelidind
+pgsql/data/base/template1/pg_procidind
+pgsql/data/base/template1/pg_procnameind
+pgsql/data/base/template1/pg_procsrcind
+pgsql/data/base/template1/pg_typeidind
+pgsql/data/base/template1/pg_typenameind
+pgsql/data/base/template1/pg_classnameind
+pgsql/data/base/template1/pg_classoidind
+pgsql/data/base/template1/PG_VERSION
+pgsql/data/base/template1/pg_internal.init
+pgsql/data/pg_variable
+pgsql/data/pg_database
+pgsql/data/pg_demon
+pgsql/data/pg_magic
+pgsql/data/pg_defaults
+pgsql/data/pg_server
+pgsql/data/pg_user
+pgsql/data/pg_hosts
+pgsql/data/pg_group
+pgsql/data/pg_log
+pgsql/data/pg_time
+pgsql/data/PG_VERSION
+pgsql/data/pg_hba.conf
+pgsql/errlog
+pgsql/post-install-notes
+@dirrm pgsql/man/man1/
+@dirrm pgsql/man/man3/
+@dirrm pgsql/man/man5/
+@dirrm pgsql/man/manl/
+@dirrm pgsql/man/
+@dirrm pgsql/lib/
+@dirrm pgsql/include/utils/
+@dirrm pgsql/include/port/BSD44_derived/
+@dirrm pgsql/include/port/
+@dirrm pgsql/include/libpq/
+@dirrm pgsql/include/lib/
+@dirrm pgsql/include/include/
+@dirrm pgsql/include/access/
+@dirrm pgsql/include/
+@dirrm pgsql/data/base/template1/
+@dirrm pgsql/data/base/
+@dirrm pgsql/data/
+@dirrm pgsql/bin/
+@dirrm pgsql/
diff --git a/databases/postgresql80-server/scripts/createuser b/databases/postgresql80-server/scripts/createuser
index 4c24a164fbd6..ceb99626e648 100644
--- a/databases/postgresql80-server/scripts/createuser
+++ b/databases/postgresql80-server/scripts/createuser
@@ -10,8 +10,8 @@ if( $> ) {
exit 1;
}
-if( getpwnam( "postgres" ) ) {
- ( $null, $null, $pgUID ) = getpwnam( "postgres" );
+if( getpwnam( "pgsql" ) ) {
+ ( $null, $null, $pgUID ) = getpwnam( "pgsql" );
} else {
$pgUID = 70;
while( getpwuid( $pgUID ) ) {
@@ -19,20 +19,20 @@ if( getpwnam( "postgres" ) ) {
}
}
-if( getgrnam( "postgres" ) ) {
- ( $null, $null, $pgGID ) = getgrnam( "postgres" );
+if( getgrnam( "pgsql" ) ) {
+ ( $null, $null, $pgGID ) = getgrnam( "pgsql" );
} else {
$pgGID = 70;
while( getgrgid( $pgGID ) ) {
$pgGID++;
}
- &append_file( "/etc/group", "postgres:*:$pgGID:" );
+ &append_file( "/etc/group", "pgsql:*:$pgGID:" );
}
-print "postgres user using uid $pgUID\n";
-print "postgres user using gid $pgGID\n";
+print "pgsql user using uid $pgUID\n";
+print "pgsql user using gid $pgGID\n";
-system( "/usr/bin/chpass -a \"postgres:*:$pgUID:$pgGID::0:0:Postgres95 pseudo-user:$ENV{'PREFIX'}/postgres95:/bin/sh\"" );
+system( "/usr/bin/chpass -a \"pgsql:*:$pgUID:$pgGID::0:0:PostgreSQL pseudo-user:$ENV{'PREFIX'}/pgsql:/bin/sh\"" );
sub append_file {
local($file,@list) = @_;
00'>2009-08-212-5/+4 * Update to 0.041.tobez2009-08-202-5/+6 * - Update to 0.024miwi2009-08-203-6/+6 * - Now the version of lib GiNaC was fixed.araujo2009-08-191-2/+2 * - Update of dependency to new math/GiNaC version.araujo2009-08-191-2/+2 * Add slave port for KDE-flavored Celestia.danfe2009-08-182-0/+12 * - Allow to build with KDE3 frontenddanfe2009-08-184-3/+128 * Over to new volunteer.linimon2009-08-171-1/+1 * Reset toxa@toxahost.ru due to maintainer-timeouts and no response tolinimon2009-08-171-1/+1 * Mark as broken on sparc64-8: needs stdlib.h instead of malloc.h. Maylinimon2009-08-171-1/+7 * Augment the description: add information about add-ons.danfe2009-08-171-1/+6 * - Update to version 1.6.0danfe2009-08-167-130/+262 * - Bump PORTREVISION in favor of math/cln update.araujo2009-08-161-2/+2 * Add my locationfluffy2009-08-111-0/+1 * - Add missing dependency.stas2009-08-101-2/+3 * - Fix build after qt updatemiwi2009-08-071-1/+2 * - Limit the stack size for Google Earth. Linux glibc threading behavesnox2009-08-072-2/+14 * - Chase astro/libnova updatedhn2009-08-053-3/+3 * - Update to 0.13.0dhn2009-08-053-10/+7 * - Fix build with qt 4.5miwi2009-08-051-2/+2 * - Add CONFLICTS for graphics/graphviz: both ports install bin/pruneamdmi32009-08-041-0/+3 * -Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.mezz2009-08-037-7/+7 * - bump all port that indirectly depends on libjpeg and have not yet been bump...dinoex2009-07-3122-14/+22 * - Update boost to 1.39pav2009-07-281-1/+1 * Update to 3.7.4jpaetzel2009-07-283-17/+30 * - Update to 0.14.1miwi2009-07-262-4/+4 * - Update to 1788.stas2009-07-213-5/+5 * - Fix dependency on jpeg, bump PORTREVISIONamdmi32009-07-211-1/+2 * Add my location & change to more accurate coordinatesyzlin2009-07-201-1/+1 * - update to jpeg7dinoex2009-07-189-17/+18 * If you have astronomical imaging of the sky with celestial coordinates you doamdmi32009-07-187-0/+176 * "WCSLIB is a C library, supplied with a full set of Fortran wrappers, thatamdmi32009-07-185-0/+100 * - Update to 0.10.2amdmi32009-07-072-4/+4 * - cleanup ADDITIONAL_LIB_DIRSdinoex2009-07-051-2/+0 * - Update to 1669.stas2009-07-032-4/+4 * - Fix installationamdmi32009-06-261-2/+2 * Prune is an application for viewing, editing and converting coordinateamdmi32009-06-255-0/+63 * - Update to 1.70miwi2009-06-184-40/+19 * - Update to 0.13.0miwi2009-06-162-4/+4 * - Chase libxcb/xcb-proto updatedhn2009-06-151-1/+1 * QLandkarte GT is the ultimate outdoor aficionado's tool. It supports GPS maps inamdmi32009-06-107-0/+81 * Convert most of remaining ports that depend on xorg-libraries toamdmi32009-06-091-3/+3 * - Update to 0.13.2amdmi32009-06-092-4/+4 * - Update to 1656.stas2009-06-092-5/+4 * - Update to 0.9.0miwi2009-06-083-15/+26 * - Update to 0.3.1miwi2009-06-062-4/+4 * - Update to 0.18dpav2009-06-012-6/+7 * - Chase astro/gpsd shlib bumpmiwi2009-05-312-3/+4 * - Update to 2.39miwi2009-05-313-10/+10 * p5-GPS-Babel is a perl interface to gpsbabel.miwi2009-05-315-0/+38 * Add my locationavl2009-05-301-0/+1 * Fix build with custom PREFIX/LOCALBASE.itetcu2009-05-301-0/+2 * - Support nondefault prefix and building with ccache by passing env through s...amdmi32009-05-301-2/+11 * - Update to 1607.stas2009-05-292-4/+5 * - Update to 1.5miwi2009-05-234-113/+219 * p5::Astro is a set of assorted astronomical routines.miwi2009-05-235-0/+40 * - Mark most of my ports MAKE_JOBS_SAFE=yespgollucci2009-05-166-0/+12 * - Update to 1566.stas2009-05-152-4/+4 * Chase updated distfile, at 5.0.11733.9347 now.nox2009-05-092-4/+4 * Add my coordinatessnb2009-05-051-0/+1 * Chase updated distfile, at 5.0.11729.1014 now.nox2009-05-053-8/+7 * Update my locationahze2009-05-021-1/+1 * - Update to 3.7.3.4miwi2009-05-013-11/+28 * - Update to 0.040jadawin2009-04-242-4/+4 * - Update to 0.13.1, support translationsamdmi32009-04-234-7/+37 * - Update to 1529.stas2009-04-212-5/+4 * Drop maintainerships.bms2009-04-211-1/+1 * - Convert linux dri dependency to USE_LINUX_APPSnox2009-04-121-1/+2 * p5-Astro-SIMBAD-Client provides an object-oriented interface tomiwi2009-04-125-0/+51 * Astro-satpass contains classes needed to predict satellitemiwi2009-04-125-0/+62 * - Update to 3.01pgollucci2009-04-102-4/+4 * Presenting GNOME 2.26 for FreeBSD. Seemarcus2009-04-101-3/+4 * - Update to 1515.stas2009-04-032-4/+5 * - Fix buildmiwi2009-04-0318-33/+295 * adopt this portxride2009-04-031-1/+1 * Add myself to the mapskreuzer2009-03-311-0/+1 * Mark MAKE_JOBS_SAFE and squash some warnings.naddy2009-03-283-0/+21 * Mark MAKE_JOBS_SAFEehaupt2009-03-271-0/+1 * astLib is a set of Python modules that provides some tools for researchmiwi2009-03-265-0/+82 * Update to 0.17ehaupt2009-03-263-8/+4 * - Update to 0.10.1amdmi32009-03-253-106/+251 * - Update to 0.039jadawin2009-03-242-4/+4 * - Do not run depend on moc.stas2009-03-211-1/+1 * - Update to 0.8.6miwi2009-03-212-4/+4 * - MOC is also required.stas2009-03-201-1/+1 * Welcome to the new linux ports infrastructure which allows usingbsam2009-03-201-1/+1 * - Update to new stable snapshot 1504.stas2009-03-193-12/+30 * Mark as broken on sparc64-7.linimon2009-03-181-0/+6 * Mark as broken on sparc64: gcc dumps core.linimon2009-03-161-1/+7 * . update graphics/exiv2 to the new version;bsam2009-03-122-2/+2 * - Update to 0.9.8rafan2009-03-112-5/+4 * - Chase libusb20 rename in r189585.stas2009-03-102-3/+41 * - Use my FreeBSD address on the ports I maintaindhn2009-03-071-1/+1 * - Mark IGNOREpav2009-03-061-0/+2 * Add tangogps 0.9.6, a comprehencive GPS mapping application.stas2009-03-056-0/+67 * - Update to 2.38miwi2009-03-013-13/+74 * - Add astro/josm, a comprehencive OpenStreetMap.org maps editor.stas2009-02-255-0/+54 * - Change default Tcl/Tk version to 8.5mm2009-02-234-2/+4 * - Update to 0.038jadawin2009-02-192-4/+4 * - Update to 1.3.6miwi2009-02-152-7/+5 * - Mark BROKEN: error: redefinition of typedef '__GLXextFuncPtr'pav2009-02-111-0/+2 * - Correct appversionpav2009-02-101-1/+1 * - Update to 0.16pav2009-02-102-5/+5 * Update to 5.0.11337.1968, adding Mars and oceansnox2009-02-053-120/+228 * - Update to software release as of 2008-09-21.pgollucci2009-02-043-5/+5 * - Mark BROKEN: does not compilepav2009-01-291-0/+2 * - Add missing imageformats qt component to depends (needed to draw map imagery)amdmi32009-01-281-1/+2 * Fix non-root build by moving the chown to a pre-su-install targetnox2009-01-251-0/+2 * Update my location.krion2009-01-241-1/+2 * Fix the build with the new curl version - the CURLOPT_USERAGENT optionroam2009-01-241-0/+11 * - Update X.org ports to 7.4+ (few ports are more recent than the katamari).flz2009-01-244-5/+7 * Bump the version of the curl shared library after the ftp/curl updateroam2009-01-233-5/+6 * In preparation for adding new linux (Fedora 8) infrastructure ports all linuxbsam2009-01-221-3/+2 * - Chase astro/libnova shlib version bumpamdmi32009-01-203-5/+4 * - Update to 0.12.3amdmi32009-01-203-5/+5 * No longer pass FC, F77 and FFLAGS to CONFIGURE_ENV; this is now done viagerald2009-01-181-1/+0 * - add LICENSE:dinoex2009-01-17