aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql84-client
diff options
context:
space:
mode:
authorgirgen <girgen@FreeBSD.org>2009-07-08 14:44:34 +0800
committergirgen <girgen@FreeBSD.org>2009-07-08 14:44:34 +0800
commite8935d775356e3b6cf453b4585bbac50abf639b6 (patch)
tree4ce1b3a1b0ab13bc6d65df5fbcf08efd13790e6a /databases/postgresql84-client
parenta3056b1215711b0d2d03a2d97ead5457071a4299 (diff)
downloadfreebsd-ports-gnome-e8935d775356e3b6cf453b4585bbac50abf639b6.tar.gz
freebsd-ports-gnome-e8935d775356e3b6cf453b4585bbac50abf639b6.tar.zst
freebsd-ports-gnome-e8935d775356e3b6cf453b4585bbac50abf639b6.zip
Welcome PostgreSQL 8.4
After many years of development, PostgreSQL has become feature-complete in many areas. This release shows a targeted approach to adding features (e.g., authentication, monitoring, space reuse), and adds capabilities defined in the later SQL standards. The major areas of enhancement are: Windowing Functions Common Table Expressions and Recursive Queries Default and variadic parameters for functions Parallel Restore Column Permissions Per-database locale settings Improved hash indexes Improved join performance for EXISTS and NOT EXISTS queries Easier-to-use Warm Standby Automatic sizing of the Free Space Map Visibility Map (greatly reduces vacuum overhead for slowly-changing tables) Version-aware psql (backslash commands work against older servers) Support SSL certificates for user authentication Per-function runtime statistics Easy editing of functions in psql New contrib modules: pg_stat_statements, auto_explain, citext, btree_gin URL: http://www.postgresql.org/docs/8.4/interactive/release-8-4.html
Diffstat (limited to 'databases/postgresql84-client')
-rw-r--r--databases/postgresql84-client/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/databases/postgresql84-client/Makefile b/databases/postgresql84-client/Makefile
new file mode 100644
index 000000000000..ec94e102a425
--- /dev/null
+++ b/databases/postgresql84-client/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: PostgreSQL-client
+# Date created: 2009-07-08
+# Whom: Palle Girgensohn <girgen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+# To depend on postgresql-client, set USE_PGSQL=yes.
+# See Mk/bsd.databases.mk for more info
+
+PORTNAME= postgresql
+PKGNAMESUFFIX= -client
+
+COMMENT= PostgreSQL database (client)
+
+MASTERDIR= ${.CURDIR}/../postgresql84-server
+
+BUILD_DIRS= config src/include src/interfaces \
+ src/bin/pg_dump src/bin/psql src/bin/scripts src/bin/pg_config \
+ doc src/makefiles
+CLIENT_ONLY= yes
+USE_LDCONFIG= yes
+
+.include "${MASTERDIR}/Makefile"