aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql84-server
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2011-10-22 04:36:06 +0800
committermm <mm@FreeBSD.org>2011-10-22 04:36:06 +0800
commit60018959053e78c492737a74c287cdc1c32278ac (patch)
tree7ffd55c8e665fb9bcbf96b348d29ad6754e379af /databases/postgresql84-server
parent507072a7bd9539b41c940c599811e48d070e9fc5 (diff)
downloadfreebsd-ports-gnome-60018959053e78c492737a74c287cdc1c32278ac.tar.gz
freebsd-ports-gnome-60018959053e78c492737a74c287cdc1c32278ac.tar.zst
freebsd-ports-gnome-60018959053e78c492737a74c287cdc1c32278ac.zip
Make SSL available as an option
PR: ports/161330 Approved by: maintainer (timeout)
Diffstat (limited to 'databases/postgresql84-server')
-rw-r--r--databases/postgresql84-server/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/databases/postgresql84-server/Makefile b/databases/postgresql84-server/Makefile
index 1ce4c92c88ac..446a371bcd34 100644
--- a/databases/postgresql84-server/Makefile
+++ b/databases/postgresql84-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= postgresql
DISTVERSION?= 8.4.9
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= databases
MASTER_SITES= ${MASTER_SITE_PGSQL}
MASTER_SITE_SUBDIR= source/v${DISTVERSION}
@@ -74,16 +74,6 @@ MAKE_ENV= PATH=${PREFIX}/bin:${PATH}
CONFIGURE_ENV+= PATH=${PREFIX}/bin:${PATH}
.endif
-# Cannot check this with standard OPTION due to a catch-22.
-# USE_OPENSSL must precede bsd.port.pre.mk, but then we don't know
-# what OPTIONS are set.
-#
-# If you *don't* want SSL, set WITHOUT_SSL=YES when making
-.if !defined(WITHOUT_SSL)
-USE_OPENSSL= yes
-CONFIGURE_ARGS+=--with-openssl
-.endif
-
.if !defined(SLAVE_ONLY)
OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= LDAP "Build with LDAP authentication support" off
@@ -101,9 +91,15 @@ OPTIONS+= ICU "Use ICU for unicode collation (server)" off
# See http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/76999 for more info
# (requires dump/restore if modified.)
OPTIONS+= INTDATE "Builds with 64-bit date/time type (server)" on
+OPTIONS+= SSL "Build with OpenSSL support" on
.endif # !SLAVE_ONLY
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_SSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-openssl
+.endif
.if !defined(SLAVE_ONLY)
. if (defined(SERVER_ONLY) && defined(WITH_ICU)) || make(makesum)
@@ -114,7 +110,11 @@ PATCHFILES+= pg-840-icu-2009-09-15.diff.gz:icu
LIB_DEPENDS+= icudata.48:${PORTSDIR}/devel/icu
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-icu4
. endif
+.endif # !SLAVE_ONLY
+
+.include <bsd.port.pre.mk>
+.if !defined(SLAVE_ONLY)
PATCH_DIST_STRIP=-p1
. if defined(WITH_PAM)