aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql91-server
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-01-22 14:59:27 +0800
committerjgh <jgh@FreeBSD.org>2012-01-22 14:59:27 +0800
commit7dfa8f6a8df113406f5ff3341dc893614da5f18d (patch)
treea93e4952d4f4fb9f21983a617fe98ffaf6ea5790 /databases/postgresql91-server
parent3a8661bdef50dfce64fe5923ae56e4069de5818c (diff)
downloadfreebsd-ports-gnome-7dfa8f6a8df113406f5ff3341dc893614da5f18d.tar.gz
freebsd-ports-gnome-7dfa8f6a8df113406f5ff3341dc893614da5f18d.tar.zst
freebsd-ports-gnome-7dfa8f6a8df113406f5ff3341dc893614da5f18d.zip
- Add profile support for PostgreSQL servers
- re-assign LOCALBASE to PREFIX - add PG_GROUP to SUB_PLIST for packaging fix - fix permissions for package installations PR: ports/162776 Submitted by: jgh, Phil Phillips < pphillips at experts-exchange.com > Reviewed by: rene (mentor) Approved by: crees (maintainer, mentor)
Diffstat (limited to 'databases/postgresql91-server')
-rw-r--r--databases/postgresql91-server/Makefile7
-rw-r--r--databases/postgresql91-server/files/postgresql.in55
-rw-r--r--databases/postgresql91-server/pkg-plist-server4
3 files changed, 59 insertions, 7 deletions
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index 8a6536c770af..4783cf7c7fa5 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= postgresql
DISTVERSION?= 9.1.2
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES?= databases
MASTER_SITES= ${MASTER_SITE_PGSQL}
MASTER_SITE_SUBDIR= source/v${DISTVERSION}
@@ -296,7 +296,8 @@ MAN7= ABORT.7 ALTER_AGGREGATE.7 ALTER_COLLATION.7 ALTER_CONVERSION.7 \
SECURITY_LABEL.7
.endif
-PLIST_SUB+= PG_USER=$(PG_USER)
+PLIST_SUB+= PG_USER=$(PG_USER) \
+ PG_GROUP=$(PG_GROUP)
SUB_LIST+= PG_GROUP=$(PG_GROUP) \
PG_USER=$(PG_USER) \
PG_UID=$(PG_UID)
@@ -355,7 +356,7 @@ do-install:
${MKDIR} ${PREFIX}/etc/periodic/daily ;\
${INSTALL_SCRIPT} ${WRKDIR}/502.pgsql \
${PREFIX}/etc/periodic/daily
- ${MKDIR} ${LOCALBASE}/${PG_USER} && ${CHOWN} ${PG_USER}:${PG_GROUP} ${LOCALBASE}/${PG_USER}
+ ${MKDIR} ${PREFIX}/${PG_USER} && ${CHOWN} ${PG_USER}:${PG_GROUP} ${PREFIX}/${PG_USER}
. endif # SERVER_ONLY
. if defined(CLIENT_ONLY)
@ cd ${WRKSRC}/src && ${SETENV} ${MAKE_ENV} ${GMAKE} install-local
diff --git a/databases/postgresql91-server/files/postgresql.in b/databases/postgresql91-server/files/postgresql.in
index ea7e9b99f7ec..643171a44b91 100644
--- a/databases/postgresql91-server/files/postgresql.in
+++ b/databases/postgresql91-server/files/postgresql.in
@@ -14,6 +14,7 @@
# postgresql_flags="-w -s -m fast"
# postgresql_initdb_flags="--encoding=utf-8 --lc-collate=C"
# postgresql_class="default"
+# postgresql_profiles=""
#
# See %%PREFIX%%/share/doc/postgresql/README-server for more info
#
@@ -39,7 +40,6 @@ postgresql_initdb_flags=${postgresql_initdb_flags:-"--encoding=utf-8 --lc-collat
name=postgresql
rcvar=postgresql_enable
-command_args="-D ${postgresql_data} ${postgresql_flags}"
extra_commands="reload initdb"
start_cmd="postgresql_command start"
@@ -50,11 +50,62 @@ status_cmd="postgresql_command status"
initdb_cmd="postgresql_initdb"
+if [ -n "$2" ]; then
+ profile="$2"
+ if [ "x${postgresql_profiles}" != "x" ]; then
+ eval postgresql_data="\${postgresql_${profile}_data:-}"
+ if [ "x${postgresql_data}" = "x" ]; then
+ echo "You must define a data directory (postgresql_${profile}_data)"
+ exit 1
+ fi
+ eval postgresql_enable="\${postgresql_${profile}_enable:-${postgresql_enable}}
+ eval postgresql_data="\${postgresql_${profile}_data:-${postgresql_data}}
+ eval postgresql_flags="\${postgresql_${profile}_flags:-${postgresql_flags}}"
+ eval postgresql_initdb_flags="\${postgresql_${profile}_initdb_flags:-${postgresql_initdb_flags}}"
+ fi
+else
+ if [ "x${postgresql_profiles}" != "x" -a "x$1" != "x" ]; then
+ for profile in ${postgresql_profiles}; do
+ eval _enable="\${postgresql_${profile}_enable}"
+ case "x${_enable:-${postgresql_enable}}" in
+ x|x[Nn][Oo]|x[Nn][Oo][Nn][Ee])
+ continue
+ ;;
+ x[Yy][Ee][Ss])
+ ;;
+ *)
+ if test -z "$_enable"; then
+ _var=postgresql_enable
+ else
+ _var=postgresql_"${profile}"_enable
+ fi
+ echo "Bad value" \
+ "'${_enable:-${postgresql_enable}}'" \
+ "for ${_var}. " \
+ "Profile ${profile} skipped."
+ continue
+ ;;
+ esac
+ echo "===> postgresql profile: ${profile}"
+ %%PREFIX%%/etc/rc.d/postgresql $1 ${profile}
+ retcode="$?"
+ if [ "0${retcode}" -ne 0 ]; then
+ failed="${profile} (${retcode}) ${failed:-}"
+ else
+ success="${profile} ${success:-}"
+ fi
+ done
+ exit 0
+ fi
+fi
+
+command_args="-D ${postgresql_data} ${postgresql_flags}"
+
postgresql_command()
{
su -l ${postgresql_user} -c "exec ${command} ${command_args} ${rc_arg}"
}
-
+
postgresql_initdb()
{
su -l -c ${postgresql_class} ${postgresql_user} -c "exec %%PREFIX%%/bin/initdb ${postgresql_initdb_flags} -D ${postgresql_data}"
diff --git a/databases/postgresql91-server/pkg-plist-server b/databases/postgresql91-server/pkg-plist-server
index bd29456e43fe..00c10a929256 100644
--- a/databases/postgresql91-server/pkg-plist-server
+++ b/databases/postgresql91-server/pkg-plist-server
@@ -765,8 +765,8 @@ share/postgresql/tsearch_data/ispell_sample.affix
share/postgresql/tsearch_data/ispell_sample.dict
share/postgresql/tsearch_data/synonym_sample.syn
share/postgresql/tsearch_data/thesaurus_sample.ths
-@exec /bin/mkdir -p %%LOCALBASE%%/%%PG_USER%% || /usr/bin/true
-@exec /usr/bin/chown %%PG_USER%%:%%PG_GROUP%% %%LOCALBASE%%/%%PG_USER%% || /usr/bin/true
+@exec /bin/mkdir -p %%PREFIX%%/%%PG_USER%% || /usr/bin/true
+@exec /usr/sbin/chown %%PG_USER%%:%%PG_GROUP%% %%PREFIX%%/%%PG_USER%% || /usr/bin/true
@dirrmtry share/postgresql/tsearch_data
@dirrmtry share/postgresql
@dirrmtry etc/periodic/daily