aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql91-server
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2011-10-06 16:46:58 +0800
committermm <mm@FreeBSD.org>2011-10-06 16:46:58 +0800
commit87f91e772e00ba093dac556d66bf6689ca54aa92 (patch)
tree7f25ced3074dcf86beadedf938e32e5e6086bc8c /databases/postgresql91-server
parent6d18546267f1e2ce0fa0eb468568bb4e6bf4e632 (diff)
downloadfreebsd-ports-gnome-87f91e772e00ba093dac556d66bf6689ca54aa92.tar.gz
freebsd-ports-gnome-87f91e772e00ba093dac556d66bf6689ca54aa92.tar.zst
freebsd-ports-gnome-87f91e772e00ba093dac556d66bf6689ca54aa92.zip
- Add ICU support to PostgreSQL 9.1 server
- Make SSL available as an option - Make portlint happier - Fix some typos PR: ports/160915 Approved by: maintainer (timeout)
Diffstat (limited to 'databases/postgresql91-server')
-rw-r--r--databases/postgresql91-server/Makefile65
-rw-r--r--databases/postgresql91-server/distinfo4
-rw-r--r--databases/postgresql91-server/files/extra-patch-icu446
3 files changed, 35 insertions, 80 deletions
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index b0de91e02921..940794cd1e76 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= postgresql
DISTVERSION?= 9.1.0
+PORTREVISION= 1
CATEGORIES?= databases
MASTER_SITES= ${MASTER_SITE_PGSQL}
MASTER_SITE_SUBDIR= source/v${DISTVERSION}
@@ -79,16 +80,6 @@ MAKE_ENV= PATH=${PREFIX}/bin:${PATH}
CONFIGURE_ENV+= PATH=${PREFIX}/bin:${PATH}
.endif
-# Cannot check this with standard OPTION due to a catch-22.
-# USE_OPENSSL must precede bsd.port.pre.mk, but then we don't know
-# what OPTIONS are set.
-#
-# If you *don't* want SSL, set WITHOUT_SSL=YES when making
-.if !defined(WITHOUT_SSL)
-USE_OPENSSL= yes
-CONFIGURE_ARGS+=--with-openssl
-.endif
-
.if !defined(SLAVE_ONLY)
OPTIONS+= DTRACE "Build with DTrace probes (server only)" off
OPTIONS+= PAM "Build with PAM support (server only)" off
@@ -99,25 +90,35 @@ OPTIONS+= OPTIMIZED_CFLAGS "Builds with compiler optimizations (-O3)" off
OPTIONS+= XML "Build with XML data type (server)" on
OPTIONS+= TZDATA "Use internal timezone database (server)" on
OPTIONS+= DEBUG "Builds with debugging symbols" off
-OPTIONS+= GSSAPI "BUild with GSSAPI support" off
+OPTIONS+= GSSAPI "Build with GSSAPI support" off
# See http://people.freebsd.org/~girgen/postgresql-icu/README.html for more info
-##OPTIONS+= ICU "Use ICU for unicode collation (server)" off
+OPTIONS+= ICU "Use ICU for unicode collation (server)" off
# See http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/76999 for more info
# (requires dump/restore if modified.)
OPTIONS+= INTDATE "Builds with 64-bit date/time type (server)" on
-#. if (defined(SERVER_ONLY) && defined(WITH_ICU)) || make(makesum)
-#USE_AUTOTOOLS= autoconf
-#CONFIGURE_ARGS+=--with-icu
-#PATCH_SITES+= http://people.freebsd.org/~girgen/postgresql-icu/:icu
-#PATCHFILES+= pg-900-icu-2010-09-19.diff.gz:icu
-#LIB_DEPENDS+= icudata.46:${PORTSDIR}/devel/icu
-#EXTRA_PATCHES+= ${FILESDIR}/extra-patch-icu4
-#. endif
+OPTIONS+= SSL "Build with OpenSSL support" on
+.endif # !SLAVE_ONLY
+
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_SSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-openssl
.endif
+.if !defined(SLAVE_ONLY)
+. if (defined(SERVER_ONLY) && defined(WITH_ICU)) || make(makesum)
+USE_AUTOTOOLS= autoconf
+CONFIGURE_ARGS+=--with-icu
+PATCH_SITES+= http://people.freebsd.org/~mm/patches/postgresql-icu/:icu
+PATCHFILES+= pg-910-icu-2011-09-22.diff.gz:icu
+LIB_DEPENDS+= icudata.48:${PORTSDIR}/devel/icu
+. endif
+.endif # !SLAVE_ONLY
+
.include <bsd.port.pre.mk>
.if !defined(SLAVE_ONLY)
@@ -189,7 +190,7 @@ LDFLAGS+= -lgssapi
. if defined(WITH_MIT_KRB5)
. if exists(/usr/lib/libkrb5.so) || exists(/usr/bin/krb5-config)
-BROKEN= "You must remove heimdal's /usr/bin/krb5-config and /usr/lib/libkrb5.so*, and set NO_KERBEROS=true in /etc/make.conf to build successfully with MIT-KRB"
+BROKEN= You must remove heimdal's /usr/bin/krb5-config and /usr/lib/libkrb5.so*, and set NO_KERBEROS=true in /etc/make.conf to build successfully with MIT-KRB
. endif
# Allow defining a home built MIT Kerberos by setting KRB5_HOME
. if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a) && exists(${KRB5_HOME}/bin/krb5-config)
@@ -328,23 +329,23 @@ SUB_FILES+= pkg-message${PKGNAMESUFFIX}
PKGMESSAGE= ${WRKSRC}/pkg-message${PKGNAMESUFFIX}
. endif
. if exists(${FILESDIR}/pkg-install${PKGNAMESUFFIX}.in)
-SUB_FILES+= pkg-install${PKGNAMESUFFIX}
-SUB_LIST= PG_GROUP=$(PG_GROUP) \
- PG_USER=$(PG_USER) \
- PG_UID=$(PG_UID)
-PLIST_SUB+= PG_USER=$(PG_USER)
-PKGINSTALL= ${WRKDIR}/pkg-install${PKGNAMESUFFIX}
+SUB_FILES+= pkg-install${PKGNAMESUFFIX}
+SUB_LIST= PG_GROUP=${PG_GROUP} \
+ PG_USER=${PG_USER} \
+ PG_UID=${PG_UID}
+PLIST_SUB+= PG_USER=${PG_USER}
+PKGINSTALL= ${WRKDIR}/pkg-install${PKGNAMESUFFIX}
. endif
.endif
.if !defined(NO_BUILD)
post-patch:
@${REINPLACE_CMD} s/@PTHREAD_LIBS@// ${WRKSRC}/src/Makefile.global.in
-#. if defined(WITH_ICU)
-# @${REINPLACE_CMD} -E -e \
-# "s|^(m4_if.*)2.6[0-9](.*Autoconf version )2.6[0-9]|\1${AUTOCONF_VERSION}\2${AUTOCONF_VERSION}|g" \
-# ${WRKSRC}/configure.in
-#. endif
+. if defined(WITH_ICU)
+ @${REINPLACE_CMD} -E -e \
+ "s|^(m4_if.*)2.6[0-9](.*Autoconf version )2.6[0-9]|\1${AUTOCONF_VERSION}\2${AUTOCONF_VERSION}|g" \
+ ${WRKSRC}/configure.in
+. endif
. if defined(SERVER_ONLY) && (${PG_USER} != "pgsql")
pre-install:
diff --git a/databases/postgresql91-server/distinfo b/databases/postgresql91-server/distinfo
index 08083ebc724f..8b557f276097 100644
--- a/databases/postgresql91-server/distinfo
+++ b/databases/postgresql91-server/distinfo
@@ -1,4 +1,4 @@
SHA256 (postgresql/postgresql-9.1.0.tar.bz2) = ec011c55194a0ac43687c0388c6567ffb534a8d0458e38b843bcd18aba027fca
SIZE (postgresql/postgresql-9.1.0.tar.bz2) = 14788869
-SHA256 (postgresql/pg-900-icu-2010-09-19.diff.gz) = 27cea46241ec814965c278330cd96f67ee03422b7758a210713a63b4b5bb77e9
-SIZE (postgresql/pg-900-icu-2010-09-19.diff.gz) = 4349
+SHA256 (postgresql/pg-910-icu-2011-09-22.diff.gz) = a88094ec22a8caeffa06d7c3a6b53d19035b171dad2acb9084da0a617a93e149
+SIZE (postgresql/pg-910-icu-2011-09-22.diff.gz) = 4373
diff --git a/databases/postgresql91-server/files/extra-patch-icu4 b/databases/postgresql91-server/files/extra-patch-icu4
deleted file mode 100644
index bf28a732a2bd..000000000000
--- a/databases/postgresql91-server/files/extra-patch-icu4
+++ /dev/null
@@ -1,46 +0,0 @@
---- configure.in.orig 2010-12-17 10:24:25.585364941 +0100
-+++ configure.in 2010-12-17 10:25:08.921592644 +0100
-@@ -947,23 +947,27 @@
- fi
-
- if test "$with_icu" = yes ; then
-- AC_CHECK_LIB(icui18n, ucol_open_44, [], [
-- AC_CHECK_LIB(icui18n, ucol_open_43, [], [
-- AC_CHECK_LIB(icui18n, ucol_open_3_8, [], [
-- AC_CHECK_LIB(icui18n, ucol_open_3_6, [], [
-- AC_CHECK_LIB(icui18n, ucol_open_3_4, [], [AC_MSG_ERROR([library 'icui18n' is required for ICU])])
-- ])
-- ])
-- ])
-+ AC_CHECK_LIB(icui18n, ucol_open_46, [], [
-+ AC_CHECK_LIB(icui18n, ucol_open_44, [], [
-+ AC_CHECK_LIB(icui18n, ucol_open_43, [], [
-+ AC_CHECK_LIB(icui18n, ucol_open_3_8, [], [
-+ AC_CHECK_LIB(icui18n, ucol_open_3_6, [], [
-+ AC_CHECK_LIB(icui18n, ucol_open_3_4, [], [AC_MSG_ERROR([library 'icui18n' is required for ICU])])
-+ ])
-+ ])
-+ ])
-+ ])
- ])
-- AC_CHECK_LIB(icuuc, ucnv_fromUChars_44, [], [
-- AC_CHECK_LIB(icuuc, ucnv_fromUChars_43, [], [
-- AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_8, [], [
-- AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_6, [], [
-- AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_4, [], [AC_MSG_ERROR([library 'icuuc' is required for ICU])])
-- ])
-- ])
-- ])
-+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_46, [], [
-+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_44, [], [
-+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_43, [], [
-+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_8, [], [
-+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_6, [], [
-+ AC_CHECK_LIB(icuuc, ucnv_fromUChars_3_4, [], [AC_MSG_ERROR([library 'icuuc' is required for ICU])])
-+ ])
-+ ])
-+ ])
-+ ])
- ])
- fi
-