aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql91-server
diff options
context:
space:
mode:
authorgirgen <girgen@FreeBSD.org>2007-02-06 23:53:24 +0800
committergirgen <girgen@FreeBSD.org>2007-02-06 23:53:24 +0800
commit9913f71a06230fa3296f339d4b476d597d7774bc (patch)
treecf2ad936e6d7a37a05558bebd8ab28090c70477f /databases/postgresql91-server
parent825a43f12d1b30a30ad6d212cbb5c1a2a97ac6d1 (diff)
downloadfreebsd-ports-gnome-9913f71a06230fa3296f339d4b476d597d7774bc.tar.gz
freebsd-ports-gnome-9913f71a06230fa3296f339d4b476d597d7774bc.tar.zst
freebsd-ports-gnome-9913f71a06230fa3296f339d4b476d597d7774bc.zip
Add option to build with LDAP authentication
Suggested by: Ederson de Moura
Diffstat (limited to 'databases/postgresql91-server')
-rw-r--r--databases/postgresql91-server/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index c43cbbd841c2..6a29d7079c62 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -85,6 +85,7 @@ BROKEN= Coredump during build on alpha 4.x
OPTIONS+= GNUGETOPT "Use GNU getopt" on
. endif
OPTIONS+= PAM "Build with PAM support (server only)" off
+OPTIONS+= LDAP "Build with LDAP authentication support" off
OPTIONS+= MIT_KRB5 "Build with MIT's kerberos support" off
OPTIONS+= HEIMDAL_KRB5 "Builds with Heimdal kerberos support" off
OPTIONS+= OPTIMIZED_CFLAGS "Builds with compiler optimizations (-O3)" off
@@ -128,6 +129,11 @@ DISTFILES+= postgresql-docs-${PORTVERSION}${EXTRACT_SUFX}
CONFIGURE_ARGS+=--with-pam
. endif
+. if defined(SERVER_ONLY) && defined(WITH_LDAP)
+CONFIGURE_ARGS+=--with-ldap
+USE_OPENLDAP= YES
+. endif
+
. if defined(WITH_INTDATE)
CONFIGURE_ARGS+=--enable-integer-datetimes
. endif