aboutsummaryrefslogtreecommitdiffstats
path: root/databases/postgresql92-server
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-12-28 05:11:42 +0800
committerjgh <jgh@FreeBSD.org>2012-12-28 05:11:42 +0800
commit02e1fc97d099bbcd151d4d44719b031707ff2158 (patch)
treeeae107e9393cc6710bb96813ea59593bc7e559a4 /databases/postgresql92-server
parent6dcfeead334d7904a23e7e5fc5b5314eab99dede (diff)
downloadfreebsd-ports-gnome-02e1fc97d099bbcd151d4d44719b031707ff2158.tar.gz
freebsd-ports-gnome-02e1fc97d099bbcd151d4d44719b031707ff2158.tar.zst
freebsd-ports-gnome-02e1fc97d099bbcd151d4d44719b031707ff2158.zip
- remove broken configurable non-default user/group for postgresql-server
- while here fix formatting of new header With hat: pgsql@
Diffstat (limited to 'databases/postgresql92-server')
-rw-r--r--databases/postgresql92-server/Makefile23
1 files changed, 6 insertions, 17 deletions
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index 8359c2b1564d..073b9c24f93f 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -1,5 +1,4 @@
-# Created by: Marc G. Fournier <scrappy@FreeBSD.org>
-#
+# Created by: Marc G. Fournier <scrappy@FreeBSD.org>
# $FreeBSD$
PORTNAME?= postgresql
@@ -40,9 +39,9 @@ GNU_CONFIGURE= yes
.undef GNU_CONFIGURE
.endif
-PG_USER?= pgsql
-PG_GROUP?= ${PG_USER}
-PG_UID?= 70
+PG_USER= pgsql
+PG_GROUP= pgsql
+PG_UID= 70
LDFLAGS+= -L${LOCALBASE}/lib
INCLUDES+= -I${LOCALBASE}/include
@@ -69,12 +68,8 @@ SERVER_ONLY= yes
USE_RC_SUBR= postgresql
USE_PGSQL= yes
WANT_PGSQL_VER= ${DISTVERSION:C/([0-9][0-9]*)\.([0-9][0-9]*).*/\1\2/g}
-USERS?= ${PG_USER}
-.if (${USERS} != "pgsql")
-UID_FILES+= ${WRKDIR}/pguid
-GID_FILES+= ${WRKDIR}/pggid
-.endif
-GROUPS?= ${PG_GROUP}
+USERS= ${PG_USER}
+GROUPS= ${PG_GROUP}
SUB_FILES+= 502.pgsql
.endif
@@ -364,12 +359,6 @@ post-patch:
${WRKSRC}/configure.in
. endif
-. if defined(SERVER_ONLY) && (${PG_USER} != "pgsql")
-pre-install:
- @${SED} -n s,pgsql,${PG_USER},gp ${PORTSDIR}/UIDs > ${WRKDIR}/pguid
- @${SED} -n s,pgsql,${PG_GROUP},gp ${PORTSDIR}/GIDs > ${WRKDIR}/pggid
-. endif
-
do-install:
@for dir in ${INSTALL_DIRS}; do \
cd ${WRKSRC}/$${dir} && \