aboutsummaryrefslogtreecommitdiffstats
path: root/databases/py-Elixir
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2007-02-14 00:19:04 +0800
committernivit <nivit@FreeBSD.org>2007-02-14 00:19:04 +0800
commit4b32eb62092ea90700e47c2ca12eb1f8925340b5 (patch)
treeede5053619a4e086b241d5c3929406288dc57a8d /databases/py-Elixir
parent7267e4bf2fe34c5033bb0238f50732298f46f54e (diff)
downloadfreebsd-ports-gnome-4b32eb62092ea90700e47c2ca12eb1f8925340b5.tar.gz
freebsd-ports-gnome-4b32eb62092ea90700e47c2ca12eb1f8925340b5.tar.zst
freebsd-ports-gnome-4b32eb62092ea90700e47c2ca12eb1f8925340b5.zip
A declarative layer on top of SQLAlchemy. It is a fairly thin wrapper, which
provides the ability to define model objects following the Active Record design pattern, and using a DSL syntax similar to that of the Ruby on Rails ActiveRecord system. Elixir does not intend to replace SQLAlchemy's core features, but instead focuses on providing a simpler syntax for defining model objects when you do not need the full expressiveness of SQLAlchemy's manual mapper definitions. Elixir is intended to replace the ActiveMapper SQLAlchemy extension, and the TurboEntity project. WWW: http://elixir.ematia.de
Diffstat (limited to 'databases/py-Elixir')
-rw-r--r--databases/py-Elixir/Makefile42
-rw-r--r--databases/py-Elixir/distinfo3
-rw-r--r--databases/py-Elixir/pkg-descr13
-rw-r--r--databases/py-Elixir/pkg-plist4
4 files changed, 62 insertions, 0 deletions
diff --git a/databases/py-Elixir/Makefile b/databases/py-Elixir/Makefile
new file mode 100644
index 000000000000..0c0a57dfa264
--- /dev/null
+++ b/databases/py-Elixir/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: py-Elixir
+# Date created: 2007-02-13
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Elixir
+PORTVERSION= 0.1.0
+#PORTREVISION= 0
+#PORTEPOCH= 0
+CATEGORIES= databases python
+MASTER_SITES= http://cheeseshop.python.org/packages/source/E/Elixir/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Declarative Mapper for SQLAlchemy
+
+BUILD_DEPENDS= ${EASY_INSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/${PYALCHEMY_EGG}:${PORTSDIR}/databases/py-sqlalchemy
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PYDISTUTILS_BUILD_TARGET= bdist_egg
+PYDISTUTILS_INSTALL_TARGET= easy_install
+PYDISTUTILS_INSTALLARGS= -O 1 -N -S ${PYTHON_SITELIBDIR} ${WRKSRC}/dist/${PYELIXIR_EGG}
+
+PLIST_SUB+= EASY_INSTALL_CMD=${EASY_INSTALL_CMD} \
+ PYELIXIR_EGG=${PYELIXIR_EGG} \
+ PYELIXIR_EGG_VER="${PORTNAME}==${PORTVERSION}"
+
+PYELIXIR_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+EASY_INSTALL_CMD?= easy_install-${PYTHON_VER}
+
+.include <bsd.port.pre.mk>
+
+PYALCHEMY_EGG!= ${MAKE} -f ${PORTSDIR}/databases/py-sqlalchemy/Makefile -V PYALCHEMY_EGG
+
+.include <bsd.port.post.mk>
diff --git a/databases/py-Elixir/distinfo b/databases/py-Elixir/distinfo
new file mode 100644
index 000000000000..ee0702532468
--- /dev/null
+++ b/databases/py-Elixir/distinfo
@@ -0,0 +1,3 @@
+MD5 (Elixir-0.1.0.tar.gz) = 6c7ca0753019ebf81b043ba2603a55ce
+SHA256 (Elixir-0.1.0.tar.gz) = 2771e40cbbb9eaff5cfe28def8f35ec920ddf9608b75c8d0594d4319eb60e05a
+SIZE (Elixir-0.1.0.tar.gz) = 88277
diff --git a/databases/py-Elixir/pkg-descr b/databases/py-Elixir/pkg-descr
new file mode 100644
index 000000000000..edf13e87d9a2
--- /dev/null
+++ b/databases/py-Elixir/pkg-descr
@@ -0,0 +1,13 @@
+A declarative layer on top of SQLAlchemy. It is a fairly thin wrapper, which
+provides the ability to define model objects following the Active Record
+design pattern, and using a DSL syntax similar to that of the Ruby on Rails
+ActiveRecord system.
+
+Elixir does not intend to replace SQLAlchemy's core features, but instead
+focuses on providing a simpler syntax for defining model objects when you do
+not need the full expressiveness of SQLAlchemy's manual mapper definitions.
+
+Elixir is intended to replace the ActiveMapper SQLAlchemy extension, and the
+TurboEntity project.
+
+WWW: http://elixir.ematia.de
diff --git a/databases/py-Elixir/pkg-plist b/databases/py-Elixir/pkg-plist
new file mode 100644
index 000000000000..d8f72e056300
--- /dev/null
+++ b/databases/py-Elixir/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+@unexec %%EASY_INSTALL_CMD%% -q -m -S %D/%%PYTHON_SITELIBDIR%% %%PYELIXIR_EGG_VER%%
+%%PYTHON_SITELIBDIR%%/%%PYELIXIR_EGG%%
+@exec %%EASY_INSTALL_CMD%% -N -S %D/%%PYTHON_SITELIBDIR%% %%PYELIXIR_EGG_VER%%