aboutsummaryrefslogtreecommitdiffstats
path: root/databases/py-MySQL/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-01-09 21:00:42 +0800
committersobomax <sobomax@FreeBSD.org>2002-01-09 21:00:42 +0800
commit2a3fb896f78f7f9ea889c0a7b03ef5a61a5091e4 (patch)
tree60f69d5f74917072ac04ac0adf15b1c3c5ac2eff /databases/py-MySQL/Makefile
parent7dc92089ccb552dab475f1c9809d5b9a7edbae2a (diff)
downloadfreebsd-ports-gnome-2a3fb896f78f7f9ea889c0a7b03ef5a61a5091e4.tar.gz
freebsd-ports-gnome-2a3fb896f78f7f9ea889c0a7b03ef5a61a5091e4.tar.zst
freebsd-ports-gnome-2a3fb896f78f7f9ea889c0a7b03ef5a61a5091e4.zip
Unbroke with python 2.2.
Diffstat (limited to 'databases/py-MySQL/Makefile')
-rw-r--r--databases/py-MySQL/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/databases/py-MySQL/Makefile b/databases/py-MySQL/Makefile
index 07f8c04f9971..17065d7ce0ea 100644
--- a/databases/py-MySQL/Makefile
+++ b/databases/py-MySQL/Makefile
@@ -19,13 +19,18 @@ USE_PYTHON= yes
.include <bsd.port.pre.mk>
-.if ${PYTHON_VERSION} != "python2.1"
+.if ${PYTHON_VERSION} != "python2.1" && ${PYTHON_VERSION} != "python2.2"
ALL_TARGET= MySQLmodule.so
.endif
+.if ${PYTHON_VERSION} == "python2.2"
+MAKEFILE_PREIN= ${FILESDIR}/Makefile.pre.in
+.else
+MAKEFILE_PREIN= ${LOCALBASE}/lib/${PYTHON_VERSION}/config/Makefile.pre.in
+.endif
pre-configure:
${CP} ${FILESDIR}/Setup ${WRKSRC}/Setup
- ${LN} -s ${LOCALBASE}/lib/${PYTHON_VERSION}/config/Makefile.pre.in ${WRKSRC}/
+ ${LN} -s ${MAKEFILE_PREIN} ${WRKSRC}/
do-configure:
cd ${WRKSRC} && ${MAKE} -f Makefile.pre.in boot