aboutsummaryrefslogtreecommitdiffstats
path: root/databases/py-SQLDict/Makefile
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>2000-10-04 04:55:20 +0800
committernectar <nectar@FreeBSD.org>2000-10-04 04:55:20 +0800
commit6517fcf773f8cd904f0709068ec6fb6734020821 (patch)
tree579a05099faf79b1ea48ce3fe0942390d3220b3f /databases/py-SQLDict/Makefile
parent4149bb4428080862138fe48e1be2c394c1433fff (diff)
downloadfreebsd-ports-gnome-6517fcf773f8cd904f0709068ec6fb6734020821.tar.gz
freebsd-ports-gnome-6517fcf773f8cd904f0709068ec6fb6734020821.tar.zst
freebsd-ports-gnome-6517fcf773f8cd904f0709068ec6fb6734020821.zip
Python dictionary wrapper around a SQL database
Diffstat (limited to 'databases/py-SQLDict/Makefile')
-rw-r--r--databases/py-SQLDict/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/databases/py-SQLDict/Makefile b/databases/py-SQLDict/Makefile
new file mode 100644
index 000000000000..54f7734f35ee
--- /dev/null
+++ b/databases/py-SQLDict/Makefile
@@ -0,0 +1,28 @@
+# Ports collection Makefile for: SQLDict
+# Date created: 10/03/2000
+# Whom: nectar@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= SQLDict
+PORTVERSION= 1.0.0
+CATEGORIES= databases python
+MASTER_SITES= http://dustman.net/andy/python/SQLDict/1.0.0/
+PKGNAMEPREFIX= py-
+
+MAINTAINER= nectar@FreeBSD.org
+
+USE_PYTHON= yes
+NO_WRKSUBDIR= yes
+
+do-build:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -c 'import SQLDict'
+ @cd ${WRKSRC} && ${PYTHON_CMD} -O -c 'import SQLDict'
+
+do-install:
+.for f in SQLDict.py SQLDict.pyc SQLDict.pyo
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PYTHON_SITELIBDIR}/${f}
+.endfor
+
+.include <bsd.port.mk>