aboutsummaryrefslogtreecommitdiffstats
path: root/databases/py-redis/Makefile
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2013-04-29 05:57:02 +0800
committerkoobs <koobs@FreeBSD.org>2013-04-29 05:57:02 +0800
commit77e78b3240edd83bf41d73ffd12f058fd556c4ee (patch)
tree69183876193b183cc22a4249689201bc22f7d158 /databases/py-redis/Makefile
parentc2de0a45d268d22e37390b1206d5ddbcdf77993f (diff)
downloadfreebsd-ports-gnome-77e78b3240edd83bf41d73ffd12f058fd556c4ee.tar.gz
freebsd-ports-gnome-77e78b3240edd83bf41d73ffd12f058fd556c4ee.tar.zst
freebsd-ports-gnome-77e78b3240edd83bf41d73ffd12f058fd556c4ee.zip
databases/py-redis: Update to 2.7.4
- Allow OPTIONSFILE to be overridden - Add regression-test: target Changes: https://github.com/andymccurdy/redis-py/blob/2.7.4/CHANGES Approved by: eadler, rm (mentors, implicit)
Diffstat (limited to 'databases/py-redis/Makefile')
-rw-r--r--databases/py-redis/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/databases/py-redis/Makefile b/databases/py-redis/Makefile
index 610e83b3b595..a2c58d764ff8 100644
--- a/databases/py-redis/Makefile
+++ b/databases/py-redis/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= redis
-PORTVERSION= 2.7.2
+PORTVERSION= 2.7.4
CATEGORIES= databases python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,14 +14,14 @@ LICENSE= MIT
USE_GITHUB= yes
GH_ACCOUNT= andymccurdy
GH_PROJECT= ${PORTNAME}-py
-GH_COMMIT= c02231c
+GH_COMMIT= b5ccc73
+
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
OPTIONS_DEFINE= HIREDIS
HIREDIS_DESC= Add py-hiredis C extension support
-# bypass infrastructure bug
-OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
+OPTIONSFILE?= ${PORT_DBDIR}/py-${PORTNAME}/options
.include <bsd.port.options.mk>
@@ -29,4 +29,7 @@ OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}hiredis>0:${PORTSDIR}/databases/py-hiredis
.endif
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+
.include <bsd.port.mk>